UX325EA Battery won't charge and shuts down immediately after removing the adapter

DCLDCL Level 1
  1. System: Windows 11
  2. Battery or AC: AC
  3. Model: UX325EA
  4. Frequency of occurrence: Constant
  5. Reset OS:
  6. Screenshot or video:

========================

Detailed description:

Hello, I am having Issues with charging my UX325EA (11th Gen i5). Today, I successfully charged it to 100%, disconnected the adapter and normally used the laptop. Battery dropped to 94% and then the laptop shut down. I tried turning it on, but it won't happen without plugging in the adapter. With adapter in, laptop works, but it doesn't charge (Battery status: 94% available (plugged in)). When I disconnect adapter, it shuts down immediately. I have latest Windows and BIOS updates. Troubleshooters and MyAsus app do not detect any problems. MyAsus app prompted me to install Power Delivery FW Upgrade, but installation fails and shuts down the laptop. I tried reinstalling battery driver, nothing happened.


Thanks for the help!

Comments

Sign In or Register to comment.