Trying to turn screenpad on

  1. System: Windows 10
  2. Battery or AC:
  3. Model: U5800GE
  4. Frequency of occurrence:
  5. Reset OS: no
  6. Screenshot or video:

========================

Detailed description:Hi, I have a zenbook pro (U5800GE) with 1st gen screenpad. I always had problems with the screenpad (not turning on) because of the software, but I always managed to fix it. Either by re-instaling drivers or by going to bios and turning it off and on. But the last time it happened, it died completely. It's not even id the device manager (hidden devices too), not in Windows 10 settings. I called service because I thought it was a hardware problem and the response was that they were going to do a windows recover or reinstall first and then check the hardware. As I use the notebook for my work, I didn't want that at all.

I was sure that the sceenpad was burned but after searching for months, I saw this post https://zentalk.asus.com/en/discussion/19291/screenpad-stay-black-problem-with-ucrtbase-dll .

There is an image there that shows the file Sceenpadserver.exe and I searched and found it in my C:\Program Files\WindowsApps folder. I realized that all the asus programs from Windows store are still there and I cannot boot them or delete them!

But Sceenpadserver.exe worked! It turned the screenpad on after months, so it wasn't burned after all. But it had no usability, it only turned the light on, nothing else. But at least now I know it works after all and I only have a software problem.

Any ideas how to fix my screenpad? Did anyone manage to do something similar and kick start it? I try to use it as it originally was. My fn+f6 shortcut is of course not working. When I open the .exe files in the "WindowsApps" folder , it opens the Windows Store and "virtually" installs the screenpad software, but it's still not working.

Thanks.

p.s Dear Asus, please write better software next time and not use Windows store

Comments

  • I try to find a solution for my problem for a long time now and as I read, a lot of people have problems with the screenpad. I downloaded every driver I found and I saw no change at all. I also tried to upgrade to screenpad 2 and it stopped and rolled back. We paid for that feature and now it doesn't work even as a simple touchpad. We need a new software suite

  • Hello boutsivariskostas,

    Since you have tried the upgrade, we will start to dig in based on this status, and leave the previous things behind.

    I would need to ask for more specific situation.

    Which step was the upgrade stopped? Please refer to below FAQ

    Also, please provide a picture of your screenpad now.

    Thank you.

  • I had problems before trying the update, but I tried to update using the "ScreenPad2_Upgrade_Tool.msi" . My bios now is 312 (the last one), I think I installed it before trying to update, not sure. You can see the errors I get. It's always the same, then it rolls back. My screenpad is total black when I boot. The only way to turn it on is using the "screenpadserver.exe", but it doesn't function at all. It's also missing from device manager (even with hidden devices on) and Windows 10 mouse options. As it's not existing at all.

    Thank you




  • Hello boutsivariskostas,

    Thank you for the pictures.

    If you have ever tried the upgrade, it would be a totally different logic to solve the problem, please kindly help to specify the scenario.

    So you have download the upgrade tool, then have you started the installation of the upgrade?

    Did the installation complete or which step were you stopped? (please refer to the FAQ above)

    Is there any "error message" ?

    I think you might need to run the upgrade again, but please provide above information first

  • Hello. I had problems (screenpad not turning on) even before trying the update. So it could be a problem before it, not sure (as it happened 3-4 months ago). But I remeber for sure that when I read about the sceenpad2 update, I thought it could fix all the problems I already had and downloaded the ScreenPad2_Upgrade_Tool.msi (I think I did it with the Upgrade Tool and not with the live update). I think the upgrade stopped at about step 7. When I run the tool again now I get the following message I send you. The same message is from Day1 I tried the upgrade. Then it rolls back.

    What I found out is that before it rolls back, it creates some folders. And then it deletes them. I copied the contents of the folders before deletion, to see if something works, but none of the .exe files work, except the "Uninstall_ScreenPad.exe" which uninstalls all the windows store apps.

    Screenpad does not appear in device manager at any form, whatever I do.



  • Hello boutsivariskostas,

    Have you ever installed your own OS? instead of using the OS coming out from factory?

    And have you updateed BIOS to verion 312?

    Thank you.

  • Hello. I use is as it was from the factory, no re-installs, no changes, I always update Windows 10 to the latest update. I do only the updates from asus tools and the site (U5800GE/HelpDesk_Download/). I installed 312 too. I downloaded the file and installed with winflash. I updated most of intel drivers too (I2C) from device manager and also using intel tools (downloadcenter.intel.com/download/28425/Intel-Driver-Support-Assistant)

  • Hello boutsivariskostas,

    Would you mind we do the restore OS again together?

    Please back up the eSupport file in your C drive, then reset the device.

    After reset, you can install the initial drivers from the eSupport files,

    then run Windows update only till all the KB are completed.

    (please do not install anything else form website and so on)

    then the live update notice for screenpad upgrade should pop up.

    run the upgrade from there.

    Le me know the result.

    Thank you very much.

  • Hello, restoring the OS was the recommendation of the local asus service too. I was hoping to avoid this procedure as I will have to reinstall the software I use. If I do it, I will post the results. Thank you for your time.

  • Amazing Content on this website.I Like it.Thanks for sharing.

  • I just hope Asus could make a new tool for screenpad. Something like a driver sweeper to reset it. OS format is not a good option and as I read in other threads, problems may continue to appear after formatting. It's a random problem

Sign In or Register to comment.