cancel
Showing results for 
Search instead for 
Did you mean: 

z590-e Motherboard BIOS update.

BHALEY84
Star I

I tried to update the BIOS on my Z590-E Motherboard and it failed the update.  I then noticed that I was suppsed to update the ME first and I didnt.  I tried to backdate the BIOS to almost every other version and it will not take any of them.  It has started just giving me the solid green light after the flashes stop from pushing the BIOS flashback button every time.  I tried a new usb as well, same outcome.  I have unplugged every usb and tried it, no change.  I have unplugged the power supply, removed the cmos battery and pressed the power buttong and clear cmos button for 30 seconds then retried the update, no change.  I get an error code 99 on the motherboard.  I removed the GPU and the capture card and retried the udpates and boot.  Nothing ever changed.  It gets stuck on the ASUS REPUBLIC OF GAMERS BIOS screen and thats it.  I try to hit F2 or DEL and it doenst respond.  

1 REPLY 1

Jiaszzz_ASUS
Moderator
Moderator

Hello, @BHALEY84 

May I inquire about the specific BIOS versions you are currently using and updating to?
We recommend avoiding significant version gaps and gradually updating to the latest BIOS version in small increments.
Could you confirm whether you are using a USB flash drive with a capacity of 1GB or more and if it meets the requirements of a single-sector USB flash drive in FAT16/32 MBR format?
Please refer to "[Motherboard] How to use USB BIOS FlashBack™" for guidance and ensure that the steps are followed correctly without any omissions.

Thank you.