Showing results for 
Search instead for 
Did you mean: 

PRIME B760M-A WIFI D4 Bios Bug

Star III


Bios PRIME B760M-A WIFI D4 BIOS 1402 and PRIME B760M-A WIFI D4 BIOS 1220 have a bug with ram memory.

I have DDR4 ram 3600mhz and when i enable XMP my ram speed stays at the lowest (2133mhz)

I need to go back to PRIME B760M-A WIFI D4 BIOS 1205 to be able to run 3600mhz.

I went to the computer store and they also tested it out and confirmed that the bios is bugged.

I hope it gets fixed because this ia very big bug


i5 12600K


Ram: Corsair Dominator DDR4 3600mhz



Star III

I used my last Asus motherboard (B150 chipset) for over 6 years and never had a problem.  The only reason I updated was to get Windows 11 capable.  Of course, the old mobo's BIOS was 5 years old so that was another incentive.  I think they stop doing BIOS updates after about 3 years.  It appears we'll be stuck on the 1205 BIOS forever unless someone at Asus wakes up and realizes they created a problem.  Pretty disappointing. 

Btw, not only did I fill out the form they sent (twice!), I did send them several screenshots.  Didn't seem to matter.  I wonder if the "support" team even sent the info the the BIOS team.  For all I know, the BIOS developers may not even know they have a problem.

I doubt Asus is still looking at this thread but just in case, I am attaching screen shots from my system after flashing the 1220 BIOS and enabling XMP.After 1220 flashAfter 1220 flashSaving with XMP enabledSaving with XMP enabledXMP but RAM still at 2133MhzXMP but RAM still at 2133Mhz1220 with XMP, RAM at 2133Mhz1220 with XMP, RAM at 2133Mhz

Hello, @lmacmil2 

Thank you for providing the relevant information and images.
Could you please provide or clarify the following details?
- the current part number, model, and spec of the G. Skill memory 
Please try installing one single memory module in the DIMM_A2 slot and clearing CMOS to confirm if it can achieve the correct speed.
- the Intel ME version, the OS version and OS build
- the brand and model name of the GPU and PSU currently installed
If you have cross-tested other memory modules, please also provide the part number of the memory and the BIOS image with the default BIOS settings.

Thank you.

I’m surprised you didn’t also ask the poor guy to send a video of him taking his RAM out and clearing CMOS while blindfolded and standing on one leg.

3 independent people with different RAM configurations all with the same result with your last two BIOS versions… think your BIOS is bugged.

Not sure what happened to the detailed reply I posted earlier today but it doesn't seem to be here so I will do it again.

1) G.Skill memory 2x8GB F4-3200C16D-GVRB.  According to the G.Skill website it is electrically the same as the -GVGB and -GVKB on the Asus approved memory list.  The only difference is the color.

2) I have previously cleared CMOS and loaded optimized defaults and that still did not let the RAM run at 3200Mhz.  I have not pulled one DIMM because it's very inconvenient and I don't why that should make a difference.  The DIMMs are in A2 and B2 as specified in the manual.

3)  I'm on Windows 11, build 22621.2715.  I believe I was on ME when I flashed the 1220 BIOS.  Yesterday I updated ME to the current version  Contrary to what your website says, flashing 1402 did not update the ME version.

4)  I do not have a discrete GPU.  I am using the on-board graphics of the i3-13100 CPU.  PSU is Corsair CS650M which was brand new when I installed the motherboard.

I have not tested any other memory.  Other users with different brand RAM have reported the same problem with the 1220 BIOS.  If a system runs as expected with the 1205 BIOS and does not run as expected with the 1220 or 1402 BIOS and no other changes have been made, then clearly the BIOS is the problem.  If Asus would spend as much time examining the code changes between 1205 and 1220 as they have trying to prove the fault is with my system, the problem would have been solved by now.