cancel
Showing results for 
Search instead for 
Did you mean: 

TUF Gaming FX505GT Laptop Not Performing Well

dathuynh555
Star III
System:
Battery or AC:
Model: TUF Gaming FX505GT
Frequency of occurrence:
Reset OS:
Screenshot or video:
========================
Detailed description:Around October 17-19, my laptop(BIOS 308, the latest offered by MyASUS) performance suddenly decreased. For example, playing videos games my FPS would be 60 normally, but now it is 9-30. Overall, there are stuttering and lagging when playing video games. My internet is working fine. Streaming videos, doing multiple tasks, or downloading, there are noticeable lag. MyASUS(V2.2.44.0) checkup shows there may be an issue with the fan. I've went to Nvidia Control Panel and set it to High-Performance Nvidia Processor, Power Option and set to High Performance and still nothing. Using Turbo mode, the fans are somewhat quiet and CPU/GPU fan kicks up to 2800-2900 RPM. Normally, using Turbo mode, the laptop emits a very loud noise and CPU/GPU fan kicks well over 5000-5500 RMP. So something is wrong here. I've also installed ASUS System Control Interface V2( V2.2.30.0) and reinstall MyASUS and the problem still persist. I've also resetted my laptop twice and it fixed nothing. I've checked Task Manager and Armoury Crate(V3.1.6.0), CPU/GPU temperatures seems fine. I'm not tech savy and not sure what is going on. Could it be CPU/GPU fan? Or motherboard? If you need more information to help a guy out, please ask.
Edit: I also should mention when I do Full Scan on Window Virus Security, it usually take 15-20 minutes and utilization of CPU is 98-99%. Now, it takes slighty longer and utilization of CPU is around 33%. I don't know if that info will help. I've also never underclocked or overlocked my CPU because I don't know how to do that.
Edit 2: I've emailed ASUS about the issue. It will take 48 hours for them to get back. I will update as soon as ASUS respond.
Thank you
157 REPLIES 157

MessBwouy
Star II
dathuynh555
  1. System:
  2. Battery or AC:
  3. Model: TUF Gaming FX505GT
  4. Frequency of occurrence:
  5. Reset OS:
  6. Screenshot or video:

========================

Detailed description:Around October 17-19, my laptop(BIOS 308, the latest offered by MyASUS) performance suddenly decreased. For example, playing videos games my FPS would be 60 normally, but now it is 9-30. Overall, there are stuttering and lagging when playing video games. My internet is working fine. Streaming videos, doing multiple tasks, or downloading, there are noticeable lag. MyASUS(V2.2.44.0) checkup shows there may be an issue with the fan. I've went to Nvidia Control Panel and set it to High-Performance Nvidia Processor, Power Option and set to High Performance and still nothing. Using Turbo mode, the fans are somewhat quiet and CPU/GPU fan kicks up to 2800-2900 RPM. Normally, using Turbo mode, the laptop emits a very loud noise and CPU/GPU fan kicks well over 5000-5500 RMP. So something is wrong here. I've also installed ASUS System Control Interface V2( V2.2.30.0) and reinstall MyASUS and the problem still persist. I've also resetted my laptop twice and it fixed nothing. I've checked Task Manager and Armoury Crate(V3.1.6.0), CPU/GPU temperatures seems fine. I'm not tech savy and not sure what is going on. Could it be CPU/GPU fan? Or motherboard? If you need more information to help a guy out, please ask.

Edit: I also should mention when I do Full Scan on Window Virus Security, it usually take 15-20 minutes and utilization of CPU is 98-99%. Now, it takes slighty longer and utilization of CPU is around 33%. I don't know if that info will help. I've also never underclocked or overlocked my CPU because I don't know how to do that.

Edit 2: I've emailed ASUS about the issue. It will take 48 hours for them to get back. I will update as soon as ASUS respond.

Thank you


TUF Gaming FX505GT Laptop Not Performing Well
I am also facing this same issue. At first, I thought it was some virus. But later I noticed that the fan is too silent even when it is "Turbo" mode. Please update if you get any follow up from the ASUS Team.
Thankyou 🙂

MessBwouy
Star II
dathuynh555

So ASUS contacted back and this was their reply:

Reset the BIOS settings.

1. Please turn off the unit completely, by holding down the power button for 30 seconds.

2. Please turn the unit on and quickly press the F2 key on the keyboard to enter BIOS.

3. Please press the F9 key in the BIOS to load optimized defaults and select yes to confirm.

4. Please press the F10 key to save and exit.


View post
Was your problem resolved after doing these steps?

patrik_subjak15
Star II
I got also this problems you guys are facing... I did write to Asus too. Waiting for respsonse. Im extremly dissapointed with Asus.

patrik_subjak15
Star II
MessBwouy

https://zentalk.asus.com/en/discussion/comment/127804#Comment_127804

Was your problem resolved after doing these steps?


View post
I tried it and i didnt resolve my problem which is exactly same.

dathuynh555
Star III
MessBwouy

https://zentalk.asus.com/en/discussion/comment/127804#Comment_127804

Was your problem resolved after doing these steps?


View post
Unfortunately, no. Resetting the BIOS(at least for me) only fixes the Turbo mode, but only temporary before it momentarily return back to the problem. I don't use Turbo mode, but I know something is wrong with it. Over all performance of laptop is lagging not just playing video games. The other option ASUS gave for me is to send it in for servicing.