cancel
Showing results for 
Search instead for 
Did you mean: 

Proximity sensor disables during call

Skwara
Star III

Asus Zenfone 10, Android 13, build WW_33.0220.0220.52.

I have an issue, where the proximity sensor stops working during a call in specific intervals (around 1 minute). When I answer a call and put the phone close to my ear, the screen gets disabled, but after a minute of holding the phone steady, close to my ear (I know the sensor is a little to the side of the speaker), the screen gets activated. Then I need to move the phone away and back, and the proximity sensor works again for around 1 minute and the problem comes back.

I tested the proximity sensor, and during the test it never showed any symptoms mentioned above. The issue seems to occur only during calls.

Using different call screens and phone apps doesn't help.

A similar issue has been reported a long time ago, but it might be a little different case than mine:
https://zentalk.asus.com/t5/zenfone-8/proximity-sensor-during-calls/m-p/244803

22 REPLIES 22

Skwara
Star III

Thank you @osstis for this input, it sounds quite pessimistic.

@Mansi_ASUS could you take a stand in regards to what @osstis wrote? Is it something that Asus is aware of? Are there any plans to address the issue that apparently exists since Zenfone 8? It seems like a significant problem in a very basic and popular activity (making calls).

Skwara
Star III

@Mansi_ASUS I managed to reproduce the issue. I'm sending a video illustrating the problem and also the gathered logs.

I also managed to find out that the issue only occurs if, during the call, the proximity sensor was covered, uncovered and covered again. Only then, the screen activates itself every minute. If the sensor is covered and kept covered throughout the call, the issue does not occur.

https://www.youtube.com/watch?v=HjSbzM0ISB8

Logs 

@Mansi_ASUS Please respond with confirmation that the above is sufficient.

erkapiter
Star II

You are a very kind and calm person. asus doesn’t know how to fix this, look at other topics, where they understand the error, they write “we’ll fix it in an update.” here they withdrew themselves. Therefore, this can only be cured by selling a smartphone. Why did I even buy it? And good luck to you in your attempts, Don Quixote.))

luancuvi
Star I

Just signed up only to report this issue.

Apparently it has been an ongoing problem since zenfone 8 and Asus is not capable or doesn't care to fix it.

 Not sure They'll let me return my phone, but I'll try

Skwara
Star III

The issue seems to be fixed with the following firmware:
https://zentalk.asus.com/t5/release-notes/231003-zenfone-10-ww-eu-33-0220-0220-75/ba-p/391477

Thank you @Mansi_ASUS for your support.