cancel
Showing results for 
Search instead for 
Did you mean: 

Windows doesn't start on Asus X554L

gy_istvan
Star I

Only the Legacy BIOS appears on the screen and nothing more. 
I replaced the original HDD with a SA400S37/480G Kingston SSD and after couple months of proper working the machine doesn't work anymore.
In the BIOS I can't see any boot option, but in the SATA configuration I see the SSD. (Also I started a windows installation and I see the SSD too, but I don't want to reinstall a windows unless it's neccessary.)
I tried to update the BIOS from version 303, but the flash utility can't recognize any bios files on the drive. Don't know why.(Formatted the usb stick to FAT32, downloaded the correct .zip then extracted it. Got a X555LAAS.312 file.)
Can you help me with this? 

Thank you in advance.

2 REPLIES 2

Falcon_ASUS
Moderator
Moderator

@gy_istvan
May I ask if your original HDD is still with you? 
If it is, please reinstall the original HDD to confirm if it can function properly.
If the original HDD is no longer available, we recommend sending your laptop to the service center for further examination.
The following is the contact information:
https://www.asus.com/support/service-center-location 

Also you can contact the local service center for help.
The following is the contact information:
https://www.asus.com/support/CallUs# 

Sorry for any inconvenience it may be caused.

gy_istvan
Star I

Hey Falcon_ASUS,

Thank you for the cooperation.
I think I will find the HDD, but I have to dig deeper in my drawer.

Let see where it goes.