"CTRL", "F9" and "left arrow" key malfunction

edited November 21 in VivoBook
  1. System: Windows 11
  2. Model: Asus Vivobook Pro 14 OLED (M3401QC)
  3. Frequency of occurrence: constant

========================

Detailed description:

I have been experiencing unusual phenomena regarding the keyboard of my Vivobook Pro 14. Namely, the "F9" and "left arrow" keys are not functioning, meaning I am unable to enable my microphone and productivity is compromised.

Troubleshooting so far:

1) Rebooting into Windows

2) Using USB keyboard as input -- the keys functioned normally using the USB keyboard

3) Booting into BIOS and testing the keyboard there -- the keys did not function properly

4) Booting into Linux Mint via USB -- the keys functioned normally in Linux; after rebooting into Windows, the keys began functioning; after restarting and going directly into Windows, the issue persisted.

5) Removing the following drivers and reinstalling them:

  • HID Keyboard Device (for some reason there are 3 of them in my device)
  • PC/AT Enhanced PS/2 Keyboard (101/102-Key)
  • ASUS Keyboard (currently not installed; cannot remember the exact name)
  • ASUS System Control Interface v3

6) Using older versions of the aforementioned drivers

7) Using keyboard troubleshooter -- no suggestions

see edit 21/11/2022)

Another note: previously the "I" and "K" keys did not function properly; this is no longer an issue (I cannot pinpoint the resolution). Furthermore, these keys would begin to function if peripheral keys were pressed (for example: I pressed "K" (did not work), then pressed "J" (worked), then pressed "K" (worked)).

I do not have restore points.

I will not attempt to factory reset since the problem is also in Linux.

This has boggled my mind for awhile now; earlier these keys would randomly start working in Windows as well. Now, they are not working as previously.

I have not tried updating BIOS yet since I would like to avoid doing that as long as possible; could this resolve the problem? (edit 21/11/2022)

EDIT 21/11/2022:

8) I have attempted to upgrade BIOS via Windows; the update did not fix the issue

9) Second attempt to boot into Linux via USB -- the keys do not work here either

10) The keys work On-Screen Keyboard and Touch Keyboard

11) NumLock does not affect keys functioning (the NumLock key does not exist on my laptop, however, I tested it with the On-Screen Keyboard

12) Linux "xev" command prints all input keys, except for "F9" and "left arrow"; this confirms that everything else works fine; this also confirms that there are no stuck keys since keylogging is not constant.

13) I attempted to warm up the internal components by using video games, suspecting this could be related to the frequent environmental temperature shifts the laptop experiences every day (it is currently winter here with negative temperatures Celsius).

14) Using my mouth to blow air under the keys is fruitless; I am not sure how I should physically clean the membrane under the keyboard

15) Quick Scan in Windows Security does not show threats

16) I am planning to test the PC under varying temperatures to determine whether this is a cold solder joint issue or not. I have used paper with very modest amount of glass cleaning liquid previously to clean the monitor and keyboard.

17) Now my "CTRL" key does not work either; this previously worked. I will definitely try to thoroughly scan for malware.

18) Malwarebytes found two mods for my games (.asi script and Cheat Engine mods) that I have deemed safe previously; I quarantined these and it did not change anything.

I have also set the endeavor to reconnect the flex cable that connect the keyboard and the motherboard. But I will not try that yet.

19) "CTRL" functionality seems to be irregular; it randomly works and randomly doesn't.

20) I have also found that my numpad does not work; could be because I messed up the driver for it but I think I have all the necessary drivers installed.

Comments

Sign In or Register to comment.