Sept 15th 2022 Android 12 Patch killed mobile data

I'd finally gotten Android 12 to the point where it was nearly stable and livable, and then the security patch yesterday completely hosed mobile data. WiFi still works. I've tried most of the tricks - restarting, resetting the network , resetting the entire phone, no joy. Anyone else fighting this? Any suggestions?

«13

Comments

  • I can't even send or receive calls since this update. I also did what you did with no luck and support is down until the 21st !!

  • Same thing here - doesn't even recognize the SIM's carrier.

  • Eeek. If this security patch has not yet arrived on a user's phone, is there a way to block it?

    Also: if it hosed "your" phone I suppose this does not necessarily mean it will hose "my" phone .. .. ubnfortunately the only way to test this is to allow its installation and see what happens, I guess :o(

  • M_1M_1 Level 1
    edited September 18

    I have two SIM cards in my phone: one has T-Mobile's network using Mint as the MVNO, and the other has AT&T's network through Straight Talk as the MVNO provider. After the software update, the SIM card that connects to AT&T's network through Straight Talk no longer connects, but the T-Mobile one is still working fine. I tried swapping the SIM cards within the phone, so I know it's not the SIM slot, and I tried the AT&T SIM in another phone and it worked fine, so I know it's not my service or the SIM card. It also stopped connecting to AT&T's network immediately after the reboot that followed the update, and it was working fine 10 minutes earlier.


    I called support and they said that they weren't aware of the issue, but that they would escalate it tomorrow. Please call them and let them know that you are experiencing it as well, otherwise they won't know that this is widespread.


    US number: 1-888-678-3688


    The broken update is Version WW-31.1010.0411.122, from 2022/09/07

  • The same thing happened to me after this update. I'm also on an AT&T-based MVNO. I'll call support tomorrow and complain.

  • Great to hear that I'm not alone in the AT&T + Straight Talk situation. Let's hope ASUS addresses this quickly!

  • I'm confused. Are we talking about a faulty security patch dated 15-SEP as in the title of this thread and reported by the OP, or a broken firmware update WW-31.1010.0411.122 dated 07-SEP as reported by mkarson86?

    For me the FW update has installed glitch free; I still await the security patch (and am still hoping not to get it).

  • M_1M_1 Level 1

    WW-31.1010.0411.122 from 07-SEP Contains the updated Android security patch to 2022-08-05. That's the latest security patch available for the Zenphone 8. Version WW-31.1010.0411.113 from 04-AUG also contains the updated Android security patch to 2022-08-05.

    My phone never got the update from 04-AUG, and was on the WW-31.1010.0410.72 version, which has the 2022-04-05 Android security patch.

    It's unclear whether it's the firmware update or the security patch that is causing the issue since, at least in my case, both were applied at the same time. However, there doesn't seem to be a problem for other devices with the security patch to 2022-08-05 (based on browsing the web, I don't personally have another device with that security patch), and this thread was created after the 07-SEP firmware was released.


    Can anyone with the WW-31.1010.0410.72 (04-AUG) version or another device that got the security patch to 2022-08-05 confirm whether AT&T MVNOs are working?

  • My problem is with regards to the WW-31.1010.0411.122 update, and I'm also on AT&T. I couldn't find any information relating to problems with the security patch from August, thus my post, so it might well be the other updates bundled with the .122 firmware that installed over the air on 2022-15-09.

  • My phone broke after installing the 31.1010.0411.122 update. In Settings → System → System update → Check details, it says:

    1. Updated Android security patch to 2022-08-05

    2. Fix the issue when full screen moving through page abnormal

    I have not tried downgrading back to 31.1010.0411.113. If anyone has, I would be thrilled to know if that fixes the problem.

  • So, just to collate some data here, we are all on AT&T SIMs on Straight Talk? Or is anyone with regular AT&T/prepaid also having this problem?

  • I'm on a a plain vanilla AT&T post paid contract, no Straight Talk. SIM is new this year.

  • @maelfactor I'm on Consumer Cellular, which is an AT&T MVNO.

  • I called support today and asked if there was a downgrade patch from .122 to .113, and all they could send me was the downgrade to Android 11, so right now the only official way to roll back is to downgrade to Android 11, then upgrade to Android 12 and patch as needed to .113.

    I can afford to wait a few days to see if something easier is published, but if anyone has already gone through that process it would be nice to know how well it worked.

  • Good to get some info. Hopefully with people contacting support, they'll address the issue for us. I'm sure this is just a small slice of how many people are actually having this issue.

  • Hi Everyone,

    So sorry for the trouble this is causing you. Can you all provide me with this information:

    1. system version:
    2. country
    3. operator

    Thank you!

  • So, I did a factory reset — didn't fix it. Downloaded the 12 to 11 downgrade file, transferred it to the phone, rebooted, never got the notification. Anyone have an idea why?

    @Karen_ASUS thanks, here you go:

    (1) WW_31.1010.0411.122

    (2) USA

    (3) Consumer Cellular, an AT&T MVNO

  • @keren_ASUS Here you go! Thanks for looking into this.

    1) 31.1010.0411.122

    2) USA

    3) Straight Talk via AT&T MVNO

  • 31.1010.0411.122

    USA

    Consumer Cellular with AT&T service.

    No mobile service at all, only wi-fi.

  • Just a follow-up on downgrading:

    tl;dr: Downgrading to Android 11 didn't fix it.

    I was able to get Android 11 installed following the instructions on Asus's Android 12 beta page. (Sorry, I can't post links yet but Google finds it if you search for Asus Zenfone 8 Android 12 Developer Preview Program. On that page, scroll down to "How to opt-out and revert back to Android 11".)

    The resulting system version is: WW_30.11.51.115. Unfortunately, this did not fix mobile service. In case it's relevant, the baseband version is now M3.13.24.45-Sake_0000110.

    I would like to try rebooting, removing/reinstalling the SIM, etc. under this version, but the phone immediately downloaded an update (WW_user_30.12.112.82) and rebooting installed that update. At that point I turned off automatic updates lol. Baseband version is now M3.13.24.55-Sake_0000110.

    So at this point I tried all the usual things (remove and reinstall SIM, network reset, factory reset, etc.), but I still have no mobile network.

Sign In or Register to comment.