Zenbook S 13 OLED BIOS request

  1. System: Zenbook S 13
  2. Battery or AC: Irrelevant
  3. Model: UM5302
  4. Frequency of occurrence: Irrelevant
  5. Reset OS: Irrelevant
  6. Screenshot or video: N/A

========================

Detailed description:


After watching so many review videos about the rumored USB4 function, I pulled the trigger on UM5302. As stated in those videos, this device needs a beta BIOS to support USB4. As I unboxed the new device and installed both latest Windows driver from AMD and tried the latest Linux kernel (5.19), I was still not able to get USB4 to work on this device. I then looked up further and realized ASUS has officially ceased support of USB4 on this device as seen here: asus website support article 1131.


I wonder if I can get a copy of the said beta BIOS, knowing that it might cause more harm than good, and be willing to take certain responsibilities? In where I live, returning an unboxed and activated unit is difficult, thus I prefer not to go through the lengthy process and just keep the device, but I absolutely need USB4 as my workflow depends on 10GbE, and there's no way I can get my jobs done without USB4.





Best Regards,


B.G.

Comments

Sign In or Register to comment.