Light sensor not working

Hi everybody,

the light sensor of my Zenfone 8 is not working.

I noticed it because when I have adaptive brigthness ON, as soon as I lock and unlock the device, the screen gets very dim (the slider is still up, and as soon as I move it, the brightness kicks up again).

Later I tried some apps that let you read your sensors measurements. I saw that every app can read every sensor, but the light sensor, which does not give any value at all (some app shows 0 or -1, because I guess that's how the variable is initialized in the app).

Is it a hardware problem? Is it common for just the light sensor to break?

Can it be a kernel/driver/firmware/software problem? I noticed this issue after a few weeks I updated to Android 12 in July (waited long because I was not sure about the big android 12 UI...) and subsequently did all the following updates. Is there any way to detect if the problem is software with something lower level than app, like adb, and maybe solve it without sending the phone to warranty?

Thank you!

Tagged:

Comments

  • AFAIK this phone can be buggy if you don't do a factory reset after updating from A11 to A12.

  • Hi @andreaemonti

    We're so sorry to hear of the issues you're facing with your ZenFone. Please try Ronzky321's suggestion, and reset your device.

    Thank you!

  • Alex'sAlex's Level 2

    @andreaemonti I've noticed the exact same issue. Only a restart does fix the issue.

  • Had the same issue here, it is gone now but I am not sure what fixed it though. It was super annoying. Brightness would drop to where I can't see at all then I manually set it to bright. Next time it would be the same issue. I have not reset my phone when I upgraded to Android 12 (and I don't plan to). Android 13 is coming soonish so I will hold out for that as I hate having to set up all of my banking and other security apps again (given that I need to get physical letters with codes to activate them)

  • Thank you everyone. I was already preparing for the factory reset, but then tried to restart the phone, and the sensor is now working again.

    I'm sorry, I feel so dumb. I thought I've already tried shutting off and on, but apparently not. Let's see if the issue comes back or not.

    Thank you for the support!

  • I have the same problem, but i can't make a factory reset bc of all the the 2FA i have installed

  • atanasuzunovatanasuzunov Level 1
    edited October 1

    For me this issue triggers when watching full-screen video (EON TV) in landscape position and answer a call. Only restart fixes it.

    ASUS told me that they cannot reproduce it.

Sign In or Register to comment.