MediaTek Wifi 6 MT7921 Auto Disconnect Problem

  1. System: Asus
  2. Battery or AC: Both
  3. Model: Tuf F17
  4. Frequency of occurrence: Frequently
  5. Reset OS: No
  6. Screenshot or video: None

========================

Detailed description:

There was a thread but was recently closed. This is STILL happening. My laptop was working fine until an update of the Bios flash ez3 which was persistent to update as usually I prefer to not update as my previous experience with updates things go wrong and after just agreeing to the update upon it's restart there is this disconnect with MediaTek wifi 6 network adapter, it just randomly switches off and can't find any networks. I done some of the previous posted methods and I got it to come bk on again twice once by changing to 802.11n which brought bk the wifi as my wifi is wifi 4 router, then next day gone no wifi had the triangle next to it so reset adapters then it came bk on put password bl into my wifi, then yep 30 mins later can't find any connections...this just goes on and on and on. I had NO problems until my updates especially the bios flash ez update. I had an asus laptop before and had NO wifi problems whatsoever, why is it the newer products are worse than the older products? I felt as well the update was forced even I had a choice of shut down without update but eventually that disappeared and only shutdown with update was available very cheeky indeed! No control over what you update and being forced into updates usually causes problems and I am correct as I got a problem from an update. Software is thrown out far too fast now bosses oh we have X amount of weeks before we have to get the product out chop chop...which leads to mistakes. I really wish software companies would stop rushing and relax take their time and check and recheck. I've NEVER had a wifi issue since my first laptop in 2008 yet 14 years later things are worse? How can that be, progress? All I see is greed not progress for humanity, the quick buck, the hacking and stealing off people. You know I hear of homeless people getting hacked just as they were building a life, this is how sad things are now people stealing from homeless, bad world we are living in now and instead of sitting creating and working we spend lots of time trying to fix problems that people are getting paid to create! This problem needs fixed ASAP and if another update could be done while the wifi is actually on for an hr or so just to update then fine or release some MAJOR patch that resolves this as it might be a combo of mediatek and bluetooth and something else that was updated during bios update. Could someone point me in the direction of learning for this side problems, is it sysadmin/networking? Somewhere along those lines as I would like to be a bit more savvy on that side of things in future instead of guessing what to do and trying lots of different ways that don't work and some that do and some are luck or coincidence it just comes bk on, who knows but it's affecting my work! Thank you

Comments

  • @camelCaseDev

    Please confirm whether the Wi-Fi device in the device manager is normal, and whether the Wi-Fi device is disconnected or not, or an exclamation mart appears.

    If the exclamation mart appears, please connect the AC adapter and follow the steps below:

    1. Update MediaTek WLAN Driver first (V3.00.01.1244 or above)

    2. Update MediaTek Bluetooth Driver again (V1.3.15.142 or above)

    3. Reboot the laptop

    Noted: If the exclamation mart does not appear in device manager, please remove the AC adapter, press the power button for 30 seconds to force shutting down, and then restart to confirm that the wireless network card is back to normal. Afterwards, please follow the steps above to re-install the WLAN/Bluetooth drivers to confirm.

  • i have the same problem, always in games.....

Sign In or Register to comment.