Zenbook UX391FA - USB-C DisplayPort Alt Mode and Thunderbolt problems

SiliconKidSiliconKid Level 1
edited April 30 in ZenBook
  1. System: Windows 11 Pro
  2. Battery or AC: AC
  3. Model: Zenbook UX391FA
  4. Frequency of occurrence: All the time
  5. Reset OS: Yes, re-installed Windows 11 Pro fresh
  6. Screenshot or video: N/A

========================

Hi

My daughter purchased a UX391FA Zenbook S in late 2020 while she was working overseas and ever since the early days of ownership she complained that a random Thunderbolt error message would pop up in Windows 10 telling her that the Thunderbolt ports require a firmware update to work properly.

SN: L5N0CV10D092216

I happen to work in IT and I repair PCs myself but because she was overseas I told her to just dismiss that message and ignore it because she didn't need to use Thunderbolt devices anyway, and I thought it was probably just a driver problem that I could sort out when she came home.

Now she is back home and wanted to connect the notebook to an external monitor via HDMI using the Asus Mini Dock she received with the notebook.

When we tried to do that I discovered the following:

  1. The notebook does detect the external monitor and correctly identifies the make, model, resolution and refresh rate of the monitor, but it does NOT send a picture to it. None of the 3 USB-C ports on the notebook will output an image to the monitor via the mini dock.
  2. All 3 USB-C ports still charge the notebook properly and if I attach the mini dock to any of the ports I am able to attach a USB 3 hard drive to the mini dock and the drive works fine and is accessible. The only thing not working appears to be DisplayPort Alt Mode.
  3. One of the Thunderbolt controllers keeps getting dropped from the device manager and the Thunderbolt error message still keeps popping up. Sometimes I see 2 Thunderbolt controllers under System Devices but sometimes I only see one.
  4. Connecting a known working CalDigit Thunderbolt 3 dock to either of the 2 Thunderbolt ports on the notebook does NOT work, the dock is NOT recognised at all and neither Thunderbolt port seems to recognise when any Thunderbolt device is attached.

I have tested the Asus mini dock on my Dell XPS15 notebook and it works perfectly with no hassle.

I have also tested both of the monitors that I have tried to use with the UX391FA (Samsung and LG) and they both work perfectly and the Dell XPS15 is able to connect to both of them via the Asus mini dock, via HDMI, and send a picture to both of them perfectly.

I therefore know conclusively that the monitors are not faulty, the HDMI cables are not faulty and the Asus mini dock is not faulty.

I have updated the BIOS of the UX391FA to version 304 (latest) and I have also downgraded the bios to 303 and 301 to test if a downgrade would resolve the USB-C / Thunderbolt problems, but it did not. I then upgraded to 304 again and the problems persist.

I have completely re-installed a fresh copy of Windows 11 onto the UX391FA using a USB-C flash drive that was prepared using the Microsoft install media tool (full hard drive clear and reformat), and that installed nice and fast, but USB-C DisplayPort alt mode is still not working and the Thunderbolt ports are still not working correctly.

I have downloaded and tried all Thunderbolt drivers available from Asus and I've tried a few other Thunderbolt drivers available from Intel and others, and none of those drivers helped.

I have also tried multiple different versions of the Intel UHD620 graphics drivers in case those were affecting DisplayPort alt mode. That didn't resolve the problem either.

I have now run out of things to try and unless I can find some kind of Thunderbolt / USB-C firmware that I can flash onto this notebook I don't know what else to do.

Is there any firmware available for the Thunderbolt controllers and / or the USB-C controller in that notebook or do I have to just assume that this motherboard is faulty at this point?

Any detailed technical input on this would be appreciated.

Thanks

Allan

Tagged:

Comments

This discussion has been closed.