FN Key and MyAsus App not working on my VivoBook X512FB X039

hurielcmadrugahurielcmadruga Level 1
edited August 3 in VivoBook
  1. System: Windows 10
  2. Battery or AC:
  3. Model: VivoBook X512FB X039
  4. Frequency of occurrence: All the time
  5. Reset OS:
  6. Screenshot or video:

========================

Detailed description:

https://youtu.be/16Mtx0LM6CY

Up there there's image and video of my two problems.

First problem: MyAsus app is showing that message "Some functions cannot be used, please restart this application or the computer"

I've already did both, I've tried to reset the app, I've searched for updates, tried a lot of things that I found on google, but it still shows this message and I can't use like 90% of the app, and that leads to the second problem.


Second problem: On MyAsus app I used to have the option to lock and unlock the FN key, but now that it doesn't works, my FN key is acting weird, like it's function is inverted. I mean, like in the video when I press FN+Esc it should turn on and off a light on the FN key and on the laptop screen show that it was locked or unlocked but now it does nothing and also the function keys (F1, F2, F3...) are working by itself without the need of locking the FN key or pressing FN before hitting the key but when I hit the function keys with the FN pressed they execute the function they should do when FN is unlocked, like lowering or increasing volume and brightness, but some of them don't work, like enabling/disabling the touch pad.


To both problems I've searched a few solutions on google but it haven't led to nothing, anyone knows any solution to this?

Comments

This discussion has been closed.