After ASUSTek Computer Inc. - System - 2.2.33.0 update, display problems

graca.dominik0graca.dominik0 Level 1
edited March 14 in VivoBook
  1. System: Windows 10
  2. Battery or AC: Both?
  3. Model: Vivobook 15 X512FL
  4. Frequency of occurrence: 100%
  5. Reset OS:
  6. Screenshot or video:

========================

Detailed description:

Hi! Windows suggested this update  ASUSTek Computer Inc. - System - 2.2.33.0 so i installed it via the intagrated windows updater. After that, i couldnt adjust brightness in the system, neither with the fn keys. And i cant connect my second monithor to the laptop, it does not "see it".

Comments

  • graca.dominik0graca.dominik0 Level 1
    edited December 2020

    I tried rolling back the update to 2.2.32.0 but it did not resolve the problem. After the first installation, the restart started with a blue screen and an installation. But after rolling it back, it did not happen. I dont know if its relavant... And in device manager when i check the properties it says that there is no driver installed, but then it shows the driver name as 2.2.32.0. I dot get it.

  • Ok. So i rolled back the firmware and the 2.2.33.0. And after that it worked. I restarted a few times because something wasnt right. And now i have the newest 2.2.33.0 version again, and the newest firmware. And still works. Strange..

  • CasperFCasperF Level 1

    Thank God you posted this because I have been getting desperate.

    I own a Asus Zenbook Pro Duo for clarity.

    @graca.dominik0 how did you roll back the firmware? The following happened to me:


    Windows update proposed me to install 2.2.33.20 (possibly fixing your problem I suppose). However, my HDMI out won't work anymore either. The strangest thing happens: Intel in fact recognizes the external screen as my third (with the dual screen on on the laptop) screen but sends no recognizable signal to any HDMI device I use. Neither over the HDMI out directly or the USB-C port. Looking at my Nvidia Control Panel PhysX menu I can actually see that it is somehow bugged because only the HDMI out is recognized and my other devices disappear, however that is not what is happening on the laptop itself, the laptop itself only uses the laptop screens.


    So I found your thread (thank god) and downloaded an older version of the firmware. But it won't let me install it because the installer says I got the latest versions and aborts the installation!


    Did you use an image backup or were you able to downgrade softwarematically?

    The 2.2.33.20 driver does not fix my HDMI out problem so I am a bit desperate.

  • My HDMI port also stopped working after "ASUSTek Computer Inc. - System - 2.2.33.20 driver" was installed. I rolled back to 2.3.33 and the problem persists. Displays plugged into the port are detected by the operating system but no video is displayed. The HDMI on my USB-C hub appears to work at least.

  • anyone know if this is affecting the G15 Zephyrus? I'm being prompted to restart and begin the update on my new machine.

  • Thiogaran AriesThiogaran Aries Level 1
    edited February 13

    Hello everyone,

    I'm also really desperate regarding this situation : I have this laptop for a couple of months now, and the main HDMI port on the left side never seemed to work. That was an issue since I can't run a VR device at all with this computer, but at least I could make an external monitor working with HDMI through a dock on the USB-C port.

    That was until 2 days ago...

    Without any change or update, my external monitor just doesn't work anymore, for no apparent reason ! It works very well with another laptop, the cables are fine too, the USB-C dock also seems to work fine. I thought maybe there was an issue with windows, so I triple-checked everything but I have no clue as to what might not work.

    Please, could anyone help ?!

    --- EDIT ---

    Next day...

    So desperate by the situation, I'm trying everything to get my external monitor to work. This morning, after I re-installed windows (and loose all my configurations at the same time...), I decided to plug back in everything I have, just like it was before the issue came up. The only thing I changed before that was the power setting, because when the computer is plugged in to the power source at home I don't like it to go into sleep mode. Then I did the plug'n'play config like it was before. And everything works. Like, the screen is immediately recognized and lights up. What the f**k.

    I still have no clue about what's going on here, but I strongly doubt that Asus put this awesome laptop on the market without double-checking the hardware. Plus, I'm pretty sure that the built-in software for the horizontal screen's management messes with the rest of the computer. The only change I could figure out here is that the display management inverted the ID numbers of the screens: before the issue I had n°1 as the main vertical screen, n°2 as the horizontal one, and n°3 as the external monitor. Now n°2 and 3 are inverted. Not sure how relevant it is.

    Anyway, long story short, I'm glad it all works fine now, and I'll try to feedback any clue that could help you guys who have the same issue to fix it.

This discussion has been closed.