Asus Zenboook Pro Duo HDMI Out not working after ASUSTek Computer Inc. - System - 2.2.33.20 driver

CasperFCasperF Level 1
edited February 26 in ZenBook
  1. System: Asus Zenbook Pro Duo UX581GV / Windows 10 Pro
  2. Battery or AC: Both
  3. Model: Asus Zenbook Pro Duo UX581GV
  4. Frequency of occurrence: Always
  5. Reset OS:
  6. Screenshot or video:

========================

Detailed description:

Windows update proposed me to install 2.2.33.20 and I did along with a few more Asus updates. However, my HDMI out won't work anymore.

The strangest thing happens: The Windows display configuration interface in fact recognizes the external screen as my third screen (with both screens enabled on the laptop) but sends no recognizable signal to any HDMI device I use. Neither over the HDMI out directly or the USB-C port. Looking at my Nvidia Control Panel PhysX menu I can actually see that it is somehow bugged because only the HDMI out is recognized and my other devices disappear, however that is not what is happening on the laptop itself, the laptop itself only uses the laptop screens.


I have already reverted to Asus drivers for Nvidia and that did not help anything. Reverting the ASUSTek Computer Inc. - System - 2.2.33.20 to either 2.2.18.0 or 2.2.33.0 doesn't work because the installer says the latest version is installed and then quits. If anyone knows a way to downgrade the system, do please let me know.


To be clear: both the HDMI out and the USB-C port are not working and show the same behaviour. It seems to be bugged because of the update so I hope for a fix soon, but I need a rollback possibilty at the moment.


Anyone any ideas?

Comments

  • CasperFCasperF Level 1

    There seems to be a comparable problem in this thread but it seemed magic to himself how he fixed it:

    https://zentalk.asus.com/en/discussion/41170/after-asustek-computer-inc-system-2-2-33-0-update-display-problems

  • LiviuLiviu Level 1

    I get for almost 4 months the please reboot to finish setting your device every time I start the laptop due to this driver and I was ignored by the dev team. I still get it to this day and I've refreshed Windows and so on. Glad to see that other people has issue with it and maybe we get a fix.

  • LiviuLiviu Level 1

    I think that he meant that he rolled back the bios, but not sure. I'm quite sure that the 308 bios version ruins the IR module of the web camera (basically, IR is not working at all, the image is blue), but if you revert back, you get gray lines and flickers on webcam.

  • LiviuLiviu Level 1

    This is another thread related to this driver.

    ASUSTek Computer Inc. driver malfunction — ZenTalk

  • Do we know any solution to this problem? I am having the same issue on my ZenBook Pro Duo UX581LV

  • 士郎士郎 Level 1

    Asus Zenboo 13 UX334FAC / Windows 10 Pro

    自分の場合は、システム2.2.33.20ドライバーが自動で更新されたあとに、PCを起動するたびにエラーが発生しました。

    表面上は問題なさそうですが、信頼性モニターを見ると、PCを起動するたびにエラーが発生しています。

    2.2.33.20ドライバーをアンインストールしてもすぐに自動で更新してしまうため、面倒ではありますがPCを初期化しました。

    初期化のあとにシステム2.2.33.20ドライバーがインストールされましたが、その後は問題なく起動しています。

    このドライバーには問題があると思います。

    少しでも参考になれば幸いです。

    (日本語です。読みづらいですがお許しください)

  • 士郎士郎 Level 1

    ZenBook13 UX334FAC

    -システム-2.2.33.20ドライバーの不具合が起きました。

    PCを起動すると動作が停止するエラーが発生します。

    初期化して改善しました。

  • LiviuLiviu Level 1
    edited January 12

    Is the same problem as mine, problem that I've reported months ago but there hasn't been any fix.

    Basically, each time we start the laptop, we get this notification, that asks us to reboot the device. This doesn't have a fix schedule, It happens daily, but if I restart the device multiple times in a day, it may or may not appear. What's for sure is that if the laptop stays close over night, in the morning the error is there.


  • My HDMI port also stopped working after "ASUSTek Computer Inc. - System - 2.2.33.20 driver" was installed. I rolled back to 2.3.33 and the problem persists. Displays plugged into the port are detected by the operating system but no video is displayed. The HDMI on my USB-C hub appears to work at least.

  • Do a full shutdown when shutting down the PC by pressing the shift key while clicking on the Shut down button and you'll not get the restart required message the next morning when booting up.

    I only got this restart message (on cold boot) because I uninstall the ALED HID driver on every system startup via a task as it's the only way now for me to turn off the LED lighting when on AC power. In the past it was possible to just restart/disable that driver and the LED gets turned off immediately but because there's been a change in the recent drivers that no longer allows you to restart, disable or uninstall any of the ASUS related drivers without restarting the PC and hence we have this problem.

This discussion has been closed.