No sound (output/input device) after computer reset on UX581GV

puzzeldpuzzeld Level 1
edited December 2020 in ZenBook
  1. System: UX581GV.308
  2. Battery or AC: Both
  3. Model: UX581-XB74T
  4. Frequency of occurrence: Always after Reset OS
  5. Reset OS: Yes, 2004 or 2009
  6. Screenshot or video: Yes

========================

Detailed description:

Windows Version: 20H2 (2009)

OS Build: 19042.610


After OS Reset there is no sound and Output/Input Device:


Device Manager is showing me the following:

(Software Update doesn't help)

Temporary workaround to get the sound working is to update SST OED driver from Windows Catalog:


Driver would be updated to version 10.24.2694.200 even though I get the following error below:

(driver error still there)


But now my sound is back (even after reboot):


However, since this is a temporary fix, how do I fix it properly?

Comments

  • LiviuLiviu Level 2
    edited November 2020

    Solution 1:

    Uninstall Intel SST from device manager, restart, go back to device manager and search for hardware change and it will automatically reinstall it.


    Solution 2:

    Search for the latest Intel Smart Sound Technology SST OED and Audio Controller drivers on Microsoft Update Catalog site (Intel media 2020 ms catalog search).

    Extract the .cab (with winzip or similar) in a directory. You'll notice that it's the same layout as if you're extracting the zip file from Asus website. So, I just grabbed the zip files from the Asus website, then extracted it and picked the pnputil.exe file with the Instal.cmd file and dropped it in the extracted .cab directory from Windows website. Then I ran Install.cmd :) (as if I were installing the Asus one).

    Install.cmd is a generic script from Asus that invoke pnputil.exe and install any INF file in the same directory.

    Kind of Tutorial from @darktears31.

    https://zentalk.asus.com/en/discussion/comment/72640#Comment_72640

  • Since we both have the same laptop, can you help me by checking this issue? It exists on both my UX581GV laptops and if it's something that affects everyone, asus should provide another bios update to fix it.

    https://zentalk.asus.com/en/discussion/39208/ir-camera-doesnt-work#latest


  • Thanks Liviu for the the reply.

    Solution 1 does not work for me.

    a. Uninstalled current Intel SST OED from Device Manager

    b. Rebooted the notebook

    c. I clicked "Scan for hardware changes" in the Device Manager

    Here are the results:




  • As for the Solution 2, it looks like it does not work for me either:

    a. Downloaded Intel Media v 10.25.0.4114


    b. Extracted .cab file to a folder with 7 zip.

    c. Downloaded Intl iSST from MyAsus app:

    d. Extracted its content to a folder

    e. Copied Install.cmd and pnputil.exe from SmartSound_DCH... folder

    f. and pasted the to the extracted Intel Media .cab file folder from Microsoft Catalog

    g. run Install.cmd from PowerShell (Administrator Mode)

    h. Rebooted the computer

    Here is the result:


    is your procedure any different from what I'm doing above or did I miss something?


  • I think that you are absolutely right that Asus needs to fix this problem ASAP.

    We purchased 5 machines for our people in graphics department but I cannot put them into the production until those problems are fixed. I will wait till the Nov 29 for the fix and if it does not happen then we will return those notebooks to the point of purchase. Just in case and in the meantime I will look for the alternative notebooks from different brand.

  • You should completely uninstall the old SST drivers before going with the 2nd Solution.

  • Okay. Here is what I did then:

    a. Uninstalled Intel SST OED device from Device Manager

    b. Run the Install from PowerShell again as per Solution 2

    c. Rebooted the computer

    However, that did not work either:


    d. So, for the next step I decided to remove both:

    • Intel SST Audio Controller
    • Intel SST OED

    e. Run the Install from PowerShell again as per Solution 2

    f. Rebooted the computer


    Unfortunately, with the same result. No sound.


  • That is a strange behavior. I also had the same issue after updating the driver using the ones from Asus driver page. For me, it worked the first solution with uninstalling and reinstalling from device manager. I tried it several times to get it right thought. Then I installed a newer version using the second solution.


    Here is the driver details of my 2nd UX581GV laptop that is untouched, meaning has the stock drivers.




  • Can you post the Intel SST OED driver version from the computer that is giving you problems, please.

  • I will get back to you once I get to use it. It's currently in use in a conference call.


    Meanwhile, another thing you could try is to disable and remove again the ISST driver, and then, install it from here:

    C:\eSupport\eDriver\Software\Driver\DCH\Offline\Smart Sound\Intel\iSST_DCH\

    These are the backup stock drivers that come with the laptop.


  • a. Removed Intel SST Audio Controller and Intel SST OED from Device Manager:


    b. Run Install.cmd from C:\eSupport\eDriver\Software\Driver\DCH\Offline\Smart Sound\Intel\iSST_DCH\10.23.0.2672\14076 in PowerShell

    c. Rebooted the computer

    Unfortunately, problem with no sound stays that same.


    For some reason the driver always reverts back to version 10.23.0.2796


    I'm going to try Reset the OS again and try last step again.

  • Reset OS Done and now trying to install Intel iSST v 10.23.0.2672 from C:\eSupport\eDriver\Software\Driver\DCH\Offline\Smart Sound\Intel\iSST_DCH\


    a. Rest OS


    b. Notebooks status after OS Reset:


    c. Disable and Uninstall Device:

    i. Intel SST OED

    ii. Intell SST Audio Controller


    d. Running Install.cmd from C:\eSupport\eDriver\Software\Driver\DCH\Offline\Smart Sound\Intel\iSST_DCH\10.23.0.2672\14076 in PowerShell

    e. Rebooted the computer

    f. And again, exactly the same result: No sound and no input/output device


  • And now this:


  • That's a nasty bug you've got there. In fact, for this laptop there were and still are quite few ones that should have been addressed.

    Firstly, the 308 BIOS locks the overclocking capabilities of the processor, which defeats any purpose of owning the HK processor version. This is not Asus fault, it's Intel's, but for the money we spent for this version, they should find a solution to this. Then, there was the webcam gray and green lines issues - that they fixed with the 308 BIOS update,

    Now, there is the IR camera issue. Nobody tested it in dark condition. Basically, the IR is not functional.

    Then, there is the driver issues, drivers that If you install them in another order (order that is not specified in the laptop manual or in the drivers webpage), some components will break, like the screenpad. Finally, if you move away from the stock OS, meaning doing a OS installation, other than the stock OS, you lose some software functionalities, like the software for the 2nd screen. It becomes just a 2nd screen, without the menu and the tweaking capabilities, and many others.

  • It looks like the computer Intel Audio Controller is on driver version 10.24.0.3694


    But, Intel SST OED is stuck on driver version:


    So I downloaded Intel Media v. 10.24.0.3694 from Windows Catalog


    a. Extracted .cab file to a folder


    b. Updated Intel SST OED to v. 10.24.0.3694 from that folder through "Let me pick from a list of available drivers on my computer" and then Have Disk


    Still got the Update Driver Warning

    and


    but the drivers was loaded:

    and the sound comeback right away


    c. Rebooted the computer

    d. Sound is still here


    but, Device Manager is still showing me that Intel SST OED has an error

    and MyAsus app is still showing me that there is a driver error


    So, the above is still a workaround but not a fix.

  • Hello puzzeld,

    May I know what kind of reset did you conduct?

    is it factory OS reset or a new OS reinstalled?

    also, was your windows version 20H2 before the reset?

    Thank you.

  • Reset This PC (with Remove everything.)

    OS before reset was Windows 10 20H2 (2009)


    Factory Reset though "F9" resets the PC to Windows 10 2004 with the same no sound result.

  • Well... finally I think I found the the fix for the no sound after OS reset. It is not Asus fix but something I found it by experimenting with the problem.

    Here are my detailed steps of what I did.

    a. OS reset


    b. After OS reset and initial setup, here is the condition of the UX581-XB74T

    No sound or output/input device

    (MyAsus Software Update does not help)


    c. Run Windows Update

    Enabled "Receive update for other Microsoft..." in Advanced options and run Windows update again


    d. Downloaded Intel iSST v10.23.0.2672 from MyAsus

    and extracted files to its default folder


    e. Search "Intel Media 2020" in Microsoft Update Catalog and downloaded Intel Media v 10.25.0.4040

    Extracted .cab file to Intel Media 10.25.0.4040 folder with 7 zip


    copied "Install.cmd and pnputil.exe from SmartSound_DCH_Intel_W10_64_v102302672 14077 folder

    and pasted the into Intel Media 10.25.0.4040 folder


    f. Uninstalled Device Intel SST OED and Audio Controller from Device Manager

    (just in case it asked you to reboot the computer, DON'T reboot it)


    g. Run Install.cmd in PowerShell from Intel Media 10.25.0.4040


    h. Reboot the computer

    You will notice that there is still no sound after reboot


    i. Uninstall Intel SST OED from Device Manager


    j. Update Intel SST Audio Controller to v 10.25.0.4040 from folder Intel Media 10.25.0.4040 in Download folder with "Have Disk" option

    You will get "Update Driver Warning" but accept it by clicking "Yes"

    Driver for Intel SST Audio Controller will updated to v.10.25.0.4040 and will also add Intel SST OED back


    k. Now, update driver for Intel SST OED from Intel Media 10.25.0.4040 folder located in Download folder with "Have Disk" option

    You might get the "Update Driver Warning" again so accept it by clicking "Yes" and the driver will be installed successfully


    You will notice that the Intel SST OED Driver was installed successfully to v 10.25.4040.217 and the driver warning beside Intel SST OED will be gone and what is the most important the YOU HAVE YOUR SOUND BACK without any errors.


    Result: Sound is back without any errors


    That's all folks

    (Special thanks to "Liviu" for some good suggestions that helped me make this happen)

  • Hello puzzeld,

    Thank you for the update.

    I have reported to dig in more about it.

    Thank you.

This discussion has been closed.