ScreenPad not working

edited September 2020 in VivoBook

I have a VivoBook S15 S532FA. When I bought it about 2 months ago the ScreenPad worked fine. About a week ago it stopped working suddenly. Pressing F6 only gives me the option now to enable or disable the touchpad. Now the ScreenPad only acts as a second screen.

When launching ScreenXpert I get the error message "ScreenXpert failed to find the following service: ScreenPadService". I've reinstalled the drivers multiple times and followed the troubleshooting guide ([Notebook] How to fix the ScreenPad 2.0 problems when it is not working properly on my ASUS notebook - Troubleshooting) as well to no avail. I can't seem to install the latest ScreenXpert Interface drivers as when I press install nothing happens. Running MyASUS tells me everything is up to date and there are no issues.

Comments

  • Hello catherine,

    Please kindly double check if your BIOS is up to date.

    Also, please noted that the installation order of the drivers in the guide must be followed,

    may you check on this as well?

    Thank you.

  • Hi Blake,

    I've updated my BIOS but I'm still having the same problem, although now when I start my laptop it tells me immediately that ScreenXpert cannot find ScreenPadService. I've looked in the App's program files and there isn't a file by that name in that folder at all. Although when I download the drivers from the ASUS website there is an .exe file by that name. If I run this as an administrator and then open ScreenXpert it will open fine. Once I restart my laptop though I have the same problem again, ScreenXpert cannot find ScreenPadService. This is a screenshot of my ScreenPad program files where you can see there is no file called ScreenPadService there:

    I have done the troubleshooting guide a few times now and nothing seems to change. I've made sure I have done it in the correct order. I have also uninstall ScreenXpert and reinstalled it twice now - this didn't fix it either. ASUS Support suggested I factory reset my laptop but I really don't want to have to do this.

  • Hello Catherine,

    Do you remember if there is any update or modification before the issue occurred?

    Another thing that came to my mind is that

    may you try to extract the files with 7-zip or WINRAR instead of the built-in extract tool,

    Then run the .exe file by Administrator?

    Thank you.

This discussion has been closed.