Screenpad stays blank

System: Windows 10
Battery or AC: AC
Description: Screenpad shows nothing
Model: UX434F
Frequency of Occurrence: Always
Reset OS: No

I've just bought this laptop today and when i started it up and installed al the drivers i wanted to try out the screenpad.

As said in the instructions for the screenpad, i hit the F6-key to switch to screenpad mode.
The touchpad started to light up and windows acted like i connected another screen. But that was it! So when switching to screenpad mode the touchpad doesn't work anymore(as it should i guess) but it stays on a blank screen.
I've tried installing different apps from the microsoft store (ScreenXpert, Screenpad Toolbar) but none of them fixes the issue.

So i just have a light up little screen without anything on it when switching to screenpad mode. The pc works fine without it but since its a feature i would like it to work.

Anyone has any idea on what to do? Feel free to ask for more info.

Comments

  • Hello gregpeeters94,
    May I know the process of how you set up?
    Was there any new OS installed?
    After you turn on the device , which driver/app did you install first and so on....
    If there is a video or a screenshot of what happened after you press F6,
    would be very helpful.
    Thank you so much.
  • Last edited by gregpeeters94 on 2019/9/20 17:10

    I just setup windows like normal after unboxing it. I continued by installing some programs like chrome and office 365, it also prompted me to update the nvidia graphics drivers so i did. After that i tried setting up the screenpad but it didn't seem to work so i thought it might have been windows updates. I continued by installing windows updates but it still didn't work.

    I tried recording it but it doesn't show it very well. The screenpad just brightens up a bit but nothing else comes up.
    [YT=width=420 height=315,align=left]6bN1A1rm-rs[/YT]

    Feel free to let me know , thanks in advance.
  • gregpeeters94 posted on 2019/9/20 17:06
    I just setup windows like normal after unboxing it. I continued by installing some programs like ch ...

    gregpeeters94,
    Thank you so much for your reply.
    May I know if you to "touchpad mode"
    is it able to be used?

    Also, if switch to "screenpad mode"
    then press WIN+P
    then chose "Duplicate"
    will the screenpad show your desktop?
  • Hello, I've bought the zenbook flip 15 and have the very same problem as gregpeeters94, did any of you find a solution in the end? 
    thanks 
  • ASUS have updated ScreenPad to Screenpad 2 and in the process broken for most (for the UK at least) the ability to use the screen pad correctly. You can following the extensive instructions to upgrade BIOS and the Screen Pad but in turn you will loose much of the functionality as the new AppDeals app required to install additional apps is not available in some territoties, like UK. ASUS themselves when contact keep giving the same information which is pointless rather than listening to people who have spent a lot of cash on their new laptops.
  • I have the same Problem and wen I do window p and select duplicate it the key pad is still black but wen I select second screen only it will make my pc screen black
  • Hello asdkj.sada1 &olimacnogard ,
    Please specify which model you possess
    and kindly record a video of how you are switching mode and how the screenpad is reacting.
    Also, if you have screenpad 2.0 please refer to below SOP to reinstall drivers
    https://www.asus.com/support/FAQ/1041344

    Also, it is fine if you switch to "second screen only" and the main screen turned off.
    Thank you.
Sign In or Register to comment.