cancel
Showing results for 
Search instead for 
Did you mean: 

I can't get LAN working on my TUF B650 Plus Wifi

spaceandtime
Star II

I've updated the firmware. I've updated all the other components. But when I attempt to install the 

Realtek RTL8125 LAN driver V1125.9.614.2022 For Windows 11 64-bit.<br/>Realtek RTL8125 LAN driver V10.60.615.2022 For Windows 10 64-bit. on Windows 11, I get this error.

failed-to-install-network.png

Right now I'm using a usb-c to ethernet to connectivity. I would like to just use my rj45.

Please let me know what to try.

Thanks,

David

1 ACCEPTED SOLUTION

Accepted Solutions

My issue was resolved with a warranty replacement Motherboard (same model). Inspection at Canada Computers confirmed there was an issue with the NIC. Thanks

View solution in original post

7 REPLIES 7

Jiaszzz_ASUS
Moderator
Moderator

Hello, @spaceandtime 

May I inquire about your current BIOS version and if there is a specific configuration requirement that prevents you from directly connecting to the rear panel's Ethernet port?


Based on the scenario you described and the screenshots provided, we recommend trying to use the Ethernet port and referring to the relevant instructions in [Motherboard] How to fix the cable network problems of Motherboard – Troubleshooting.

Thank you.

spaceandtime
Star II

Hi Jiaszzz,

Based on the chart above my ethernet port is Off. The Activity Link LED and Speed LED are off when I connect a RJ-45 cable.

The bios I installed is
Version: 1811 x64
Date: 10/07/2033
AGESA Version: ComboAM5PI_1080
LED EC Version: AULA3-AR32-0220

Thank you,

Hello, @spaceandtime 

May I ask if the situation you described happened after any changes were made?
For example, updating the BIOS or connecting an external device
Could you please specify the troubleshooting steps you have taken so far?
Have you consulted the provided FAQ for initial issue troubleshooting and cleared the CMOS?
Is the lack of network connectivity a persistent issue, or does it occur sporadically after booting up?
We recommend check whether the network device in Device Manager is abnormal, test with an alternative RJ-45 cable to further verify, and refer to the [Windows 11/10] Troubleshoot app if needed. 

Thank you.

Hi Jiaszzz,

I recently put this system together. I purchased the Asus motherboard at my local Canada Computers. I put it all together. 

When I ran Win11 install it didn't detect the RJ45. I was able to workaround it using my USB-C to Ethernet.
As mentioned I have never seen the LED Ethernet activate. I have two ethernet cables. Both work with near by computers, so I believe that can be ruled out. I tried updating BIOS, Had a lot of trouble with the EZ loader. Switched to using USB Port to install new BIOS without issue.  Regarding FAQ / check list:

1. Make sure the internet cable is well connected: Done

2. Check whether the network device in Device Manager is abnormal: Done, see screenshot

3. Enter Network and Internet for troubleshooting: Doesn't detect any issue

4. Default the Internet Setting: Tested right after install no impact

5. Unable to get access to internet because of browser: This works with the USB-C dongle

6. Fix network connection issues in Windows: Doesn't detect an issue

7. Reset the system: Done no impact.
I have not tried the CMOS. I will try that later today and let you know how it goes. 

Thanks for your help