Why can't I add widgets on third-party launchers with Android 12

NTICompassNTICompass Level 1
edited July 24 in ZenFone 8

I just got a Zenfone 8, and I updated it to Android 12 (UL-I006D-ASUS-31.1010.0410.43-1.1.25-2202-user.zip). I installed Nova Launcher, and I cannot widgets.

Video: drive.google.com/file/d/10N5oYJ3oG_wWFjtLtrKT5C0awkV49P75/view?usp=sharing

Looking at Nova's logs, I see:

java.lang.NullPointerException: Attempt to read from field 'com.android.server.appwidget.AppWidgetServiceImpl$ProviderId com.android.server.appwidget.AppWidgetServiceImpl$Provider.id' on a null object reference

So, it seems ASUS's Android 12 build is missing something from its settings app.

Does anyone else have an issue adding widgets? I tried Lawnchair and have the same issue. ASUS Launcher obviously works fine.

I should probably note that my phone is rooted, but that shouldn't matter, right?

Best Answer

  • NTICompassNTICompass Level 1
    Answer ✓

    I just updated to 31.1010.0410.61 and now the widgets work!

    I had to manually download the ZIP file from www.asus.com/us/Mobile/Phones/ZenFone/Zenfone-8/HelpDesk_Download/ and then rename it to UL-I006D-ASUS-31.1010.0410.61-1.1.25-2204-user.zip

    Then after a reboot, the update was detected and installed. After the update was installed, I opened Magisk and installed to the "inactive slot (after OTA)."

    Then when the phone booted into the new update, the widgets worked! I tried, and got the "do you want to add widgets" dialog and it all worked :-)


  • landsomelandsome Level 2

    Works fine in my case. Nova also.

  • Yeah, it seems to just be an issue for me. Maybe I did something wrong when I installed the Android 12 update...

  • asrulzasrulz Level 1

    Same here. Unable to add almost all kind of widget on 3rd party launcher. Been trying on few launchers and all return with same problem.

  • I've found I'm not the only one with this issue, but I'm not sure what's going on. I am waiting for ASUS to release an update (a new version of Android 12) that fixes this.

  • asrulzasrulz Level 1

    Under Android 12, can you add new widget into your phone Nova launcher?

  • anthopanthop Level 1

    I am having the same issue and see the same NullPointerException. I'm running the latest ASUS-provided build of Android 12. I've tried this with multiple third-party launchers and have the same problem, so this is not restricted to Nova. Phone is not rooted.

    Contacted Nova's support, and they suggested that this is an issue with ASUS' Android 12 builds.

  • ibo13700ibo13700 Level 1

    Hello I used to use Nova too and at first launch when you want to put a widget on the screen there is a prompt asking to allow Nova to set widgets. Maybe you accidentally rejected it? If that's the case maybe you should wipe Nova's datas and start from scratch?

  • I never saw the prompt. It just freezes/crashes. I tried uninstalling and reinstalling Nova, but that didn't help.

    I'm not totally sure what's going on.

  • pozeromonpozeromon Level 1

    Same problem here, I have a ROG Phone 5s Pro and got exactly same issue, just updated on April 26th and the error keeps there.

  • Mystery MartMystery Mart Level 1
    edited May 5

    Me too! Rog Phone 5. All third party launchers suffer the same problem when adding widgets. Most require a phone reboot to by pass issues. Indeed, as previously mentioned, the pop up that normally appears to create widgets on first use which has always been seen on previous Android versions was missing on Android 12. Any chance of a fix?

  • asrulzasrulz Level 1
    edited May 7

    The latest firmware update solve this issue for me. Now I can add widgets to my 3rd party launcher.

  • I'm up to date with the latest firmware and it hasn't sorted out my problem!

  • NTICompassNTICompass Level 1

    I'm not exactly sure what fixed my issue, other than just installing the update.

    So, I'm not sure why it works or doesn't work.

  • 24/05/22 update has cured this problem for me. Good news👍

  • MachiMachi Level 1

    i hate android 12

    I cannot downgrade my rog phone 5s pro to android 11

  • Thread automatically closed due to inactivity. If the reported issue has not been resolved or you require further assistance from one of our moderators, please create a new thread and we will be with you shortly.

This discussion has been closed.