cancel
Showing results for 
Search instead for 
Did you mean: 

Why can't I add widgets on third-party launchers with Android 12

NTICompass
Star II
I just got a Zenfone 8, and I updated it to Android 12 (UL-I006D-ASUS-31.1010.0410.43-1.1.25-2202-user.zip). I installed Nova Launcher, and I cannot widgets.
Video: drive.google.com/file/d/10N5oYJ3oG_wWFjtLtrKT5C0awkV49P75/view?usp=sharing
Looking at Nova's logs, I see:
java.lang.NullPointerException: Attempt to read from field 'com.android.server.appwidget.AppWidgetServiceImpl$ProviderId com.android.server.appwidget.AppWidgetServiceImpl$Provider.id' on a null object reference
So, it seems ASUS's Android 12 build is missing something from its settings app.
Does anyone else have an issue adding widgets? I tried Lawnchair and have the same issue. ASUS Launcher obviously works fine.
I should probably note that my phone is rooted, but that shouldn't matter, right?
1 ACCEPTED SOLUTION

NTICompass
Star II
I just updated to 31.1010.0410.61 and now the widgets work!
I had to manually download the ZIP file from www.asus.com/us/Mobile/Phones/ZenFone/Zenfone-8/HelpDesk_Download/ and then rename it to UL-I006D-ASUS-31.1010.0410.61-1.1.25-2204-user.zip
Then after a reboot, the update was detected and installed. After the update was installed, I opened Magisk and installed to the "inactive slot (after OTA)."
Then when the phone booted into the new update, the widgets worked! I tried, and got the "do you want to add widgets" dialog and it all worked 🙂

View solution in original post

17 REPLIES 17

landsome
Rising Star II
Works fine in my case. Nova also.

NTICompass
Star II
andreescul

Works fine in my case. Nova also.


View post
Yeah, it seems to just be an issue for me. Maybe I did something wrong when I installed the Android 12 update...

asrulz
Star II
Same here. Unable to add almost all kind of widget on 3rd party launcher. Been trying on few launchers and all return with same problem.

NTICompass
Star II
asrulz

Same here. Unable to add almost all kind of widget on 3rd party launcher. Been trying on few launchers and all return with same problem.


View post
I've found I'm not the only one with this issue, but I'm not sure what's going on. I am waiting for ASUS to release an update (a new version of Android 12) that fixes this.