Unable to switch from RAID to AHCI in BIOS

netsyspronetsyspro Level 1
edited June 25 in ZenBook
  1. System: Zenbook Flip 15, 1TB SSD, 16GB RAM
  2. Model: Q538EI

========================

Detailed description:I have shrunk the C: partition in Windows 11 so I can have 800GB available to install Linux. Unfortunately the Linux installer cannot see the disk. It is my understanding that one needs to make a change in the BIOS for the disk from RAID to AHCI. I have done this on older ASUS systems but I am not able to do that so far in the BIOS on this laptop.

Given I don't like to use Windows I need to find a solution for this problem.

ASUS BIOS Version 311

GOP Version: 12.0.1044

EC Version: F0062109.30A

If anyone has the solution I would be most indebted.

Thank you

Comments

  • Did you enables intel optane memory in bios, if yes means, then disable it.

  • netsyspronetsyspro Level 1
    edited May 26

    I presume you are talking about Advanced Intel Rapid Storage Technology?

    The only place I see Intel Optane mentioned is on Boot Option #1 where it lists Windows Boot Manager (Intel Optane). If I change that the only other boot option would be a bootable USB.

    I have the ability to disable Intel RST. When I select Disable it is telling me this could take from a couple of minutes to several hours and not to restart the computer until it has finished.


    I found the below which looks relevant (this site won't let me post the link.)

    It’s not uncommon to find a system on which RAID drivers have been installed and something like the Intel Rapid Storage Technology package is handling storage devices, but where an SSD might require AHCI operation for more optimal performance or configurability. In these cases, there is in fact a way to switch operation from either IDE or RAID to AHCI within Windows 10 without having to reinstall. Here’s how.

    1. Right-click the Windows Start Menu. Choose Command Prompt (Admin).
      1. If you don’t see Command Prompt listed, it’s because you have already been updated to a later version of Windows. If so, use this method instead to get to the Command Prompt:RClick the Start Button and type cmd
      2. Right-click the result and select Run as administrator
    2. Type this command and press ENTER: bcdedit /set {current} safeboot minimal
      1. If this command does not work for you, try bcdedit /set safeboot minimal
    3. Change the SATA Operation mode to AHCI from either IDE or RAID (again, the language varies).
    4. Save changes and exit Setup and Windows will automatically boot to Safe Mode.
    5. Right-click the Windows Start Menu once more. Choose 
    6. Restart the computer and enter BIOS Setup (the key to press varies between systems).Command Prompt (Admin).
    7. Type this command and press ENTER: bcdedit /deletevalue {current} safeboot
      1. If you had to try the alternate command above, you will likely need to do so here also: bcdedit /deletevalue safeboot

    Reboot once more and Windows will automatically start with AHCI drivers enabled.


    I also found the below which makes sense to me.

    Is it OK to disable Intel Rapid Storage Technology? Warning: Do not disable Optane memory in BIOS unless you have first disabled the feature in the Intel RST application in Windows, else your drive and data will be inaccessible.

    If I am reading all of this right I think I first need to steps 1 & 2 above and then disable the Intel RST Windows service. Then go into BIOS and disable Intel RST and lastly boot back into Windows and do steps 5-7.

    Please advise.

    Thank you.

  • Thread automatically closed due to inactivity. If the reported issue has not been resolved or you require further assistance from one of our moderators, please create a new thread and we will be with you shortly.

This discussion has been closed.