Phone Freezes, Restarted and now stuck in Bootloop

Ralph ChristianRalph Christian Level 2
edited September 15 in ROG Phone 2

Please tell us some basic information before asking for help:

  1. Model Name: ROG Phone 2 Ultimate Edition ( 1 TB )
  2. Firmware Version: Latest
  3. Rooted or not: Not Rooted
  4. Frequency of Occurrence: 2
  5. APP Name & APP Version (If your issue relates to the app): Genshin Impact Latest Version

In addition to information above, please also provide as much details as you can, e.g., using scenario, what troubleshooting you've already done, screenshot, etc.

========================================


I've updated the game "Genshin Impact" before updating that phone was working well.

Then once it got updated the phone freezes then I tried to do a hard power off by holding the power button for 10 to 15 seconds. But it didn't turn off right away so I tried to hold it again and it turned off.


While I was waiting for my phone to restart the phone boot looped. I tried to go to recovery mode and wiped the data and it seems it didn't find any file.


Can you please help why did this occur. Been taking care of this phone a lot. and it will be it's 3rd year this coming months.



Tagged:

Comments

This discussion has been closed.