"Some functions cannot be used, please restart this application or the computer" error pops up

arunnikhil6arunnikhil6 Level 1
edited August 11 in Others
  1. System: Windows 10
  2. Battery or AC:
  3. Model: Asus TUF Gaming FX505GT
  4. Frequency of occurrence:
  5. Reset OS:
  6. Screenshot or video:

========================

Detailed description:In MyAsus application, this error popups "Some functions cannot be used, please restart this application or the computer". And some Fn keys are also not working, such as Fn+F4, Fn+F5, Fn+F6 and Fn+F10. Please somebody help me through this matter.


Comments

  • Hi there,

    Please kindly check the version of your ASUS System control interface V3

    The latest version is V3.0.9.30.

    Please kindly update and reboot the device.

    Thank you.

  • Hi Blake,

    I downloaded and installed the latest version of Asus System Control Interface V3 v3.0.9.30, but the error remains the same there. Here are the screenshots.


  • Hi there,

    so the same after you reboot?

    how about your armoury crate version?

    Thank you.

  • Hello Blake,


    When I try to open Armoury Crate, it shows this error: "Service Error: Certain Armory Crate features may be disabled because some ASUS applications are not running properly. Go to Armory Crate FAQ page for troubleshooting and re-enable all the features."

  • Hi Blake,


    I forgot to mention, the version of Armoury Crate in my laptop is 4.0.12.

  • Hi arunnikhil6,

    Please kindly use the uninstall tool and installer from below link

    To install the latest Armoury Crate.

    And reboot the device again.

    Thank you.

  • arunnikhil6arunnikhil6 Level 1
    edited July 3

    Hello Blake,


    So as you told, I updated the Armoury Crate and thus there is no error in it now. But still the problem exists in MyAsus. The error has not gone till yet. And some Fn keys, as previous, not working till now. Check out the screenshot.

  • Somebody in this forum, please help me to get out of this.

  • Hi there,

    This issue hasn't been seen for a while.

    But there was 1 short tern solution is that

    reboot the device, and after reboot, do not open Armoury Crate.

    Keep the device connected to the internet and stay idle for 15 minutes.

    Then open MyASUS and Armoury Crate to see if you still have the issue.

    If so, please consider to reset the device.

    Thank you.

  • arunnikhil6arunnikhil6 Level 1
    edited July 9

    Hello Blake,


    The problem has been solved. After the update of latest driver came up of Asus System Control Interface on 7th July, 2021 on my Drivers section, now everything is working fine. Thank you for your support!

  • Thank you so much for the update!

This discussion has been closed.