Asus system control interface not available for zenbook pro 15

a.b.santhosh02a.b.santhosh02 Level 1
edited March 19 in ZenBook
  1. Battery or AC: Battery/AC
  2. Model: UX580GE
  3. Frequency of occurrence: Everyday
  4. Reset OS: 2+ times
  5. Screenshot or video:

System: zenbook pro 15

Detailed description:

My device is not compatible for the asus system control interface driver? Are you Fu*king kidding me? I paid $2k for a device and this is how you give software support?

I'm already mad at the fact that my device's battery died only in a year of normal using and asus doesn't even care to replace the battery and this? I've been suffering ever since I bought this device.

That aside, I need the appropriate drivers. I just can't miss out on all the software paying a premium.


Edit1: I request the mods to give an useful solution rather than just pointing me to random asus page. I've visited almost all of em. And I expect working solutions from people who ACTUALLY had this issue and fixed it somehow. Thank you in advance

Comments

  • Hey,

    Thanks for responding.

    Can you tell what part of "My device is not compatible for the asus system control interface driver?" you didn't understand so I can explain it to you again?

    Its fine. Ill rephrase it for you.

    "My device is not compatible for the asus system control interface driver?"

    This means my model is not supported BY THE FREAKING DRIVER!! GOT IT?! THATS WHY I'M HERE IN THE FIRST PLACE!

  • edited January 31

    do you know eventhough my laptop model number is not mentioned in both the version v1 and V2 in pdf.

    eventhough I successfully installed asus system center interface V2 using device manager .

    before installing that particular device driver , will not show in device manager under system devices.

    you need to download my asus application from Microsoft store and then log using asus account. and then reply to me

  • Alright. After the hint you gave,

    "I successfully installed asus system center interface V2 using device manager"

    I downloaded the asus system control interface driver from DriveHub and used device manager to install the driver.

    I must say sorry and thank you. But this is not it. I still have plenty of problems to fix in my device. Guess you'll see me around often.

    Before this thread is closed, I'd like to make a detailed Instruction set on how to install the driver even if the official asus page says that their brand new premium device is "old" and does not support most MyAsus features and also because there is literally no Asus page that mentions this.


    DriveHub link:- https://www.drvhub.net/devices/chipsets/asus/system-control-interface-v2

  • Could youy tell me the probelms of device , if i know i the idea, i will give solutions if possible .

    Do you know i have collected many drivers of asus system center interface driver from asus suport page , i stored in d drive

  • Hello a.b.

    The ASUS System Control Interface V1 V2 compatibility is based on the design of motherboard, so it's hardware difference that can not be changed.

    Your device was designed before the driver was designed, so it is not supported.

    Is there specific function you need so you want to use the driver?

    Thank you.

  • "Is there specific function you need so you want to use the driver?"

    Yes. My device's battery is dead. I've already tried contacting various service centers near me and none of them have spare battery to test because this model is "rare".

    Someone in some forum suggested to use the battery diagnostic tool in MyAsus to check battery health.

    Unfortunately, The first class software provided by asus said my battery have "1" problem and suggests me to take it to the service center.

    And one more thing. Where is the screenpad sdk? was it just a joke like your software support?

    p.s. I really hate the new screenpad ui. I loved to use the screenpad when it had the default UI and navigation. It all started when you tried to replicate mobile interface for the screenpad and failed miserably. I almost never used the screenpad now because of that. Atleast give an option to change it to screenpad 1.0 and don't tell me that that's a bios thing and you need to change the hardware for that. That's bs.

  • Hello a.b.

    Battery can be tested in the service center, for all model. Please send the device to service center for such issue.

    Battery can be replaced after it is tested fail.

    For the screenpad SDK, I'm sorry that I have not received any further information.

    Thank you.

  • Let me tell you what exactly they told to me.

    "Sir, as this is a new model, We don't have spare battery to test if the problem is with the device or the software. It will take more than a week to receive the battery from HQ." I said ok, take your time and check the device.

    After 2 weeks, they called me over phone and said "We couldn't get hold of a battery atm. Battery for this model is not available. Please take back your device. The service charge will be xyz. Thank you"

    That's it. This happened with almost all the centers I've contacted over time.

  • Hello a.b.

    The service center can run the test program on the battery, they might not have a spare battery for you to cross check.

    After your battery is tested fail by the program, they can order a battery for you and replace it for you.

    Due to recent situation, the part might come slow but shouldn't be no part.

    They can not order the battery without a reason, so there might be some misunderstanding.

    Thank you.

This discussion has been closed.