Asus VivoBook F510-UA not detecting SSD in M.2 slot

awesomesaadkhanawesomesaadkhan Level 1
edited February 1 in VivoBook

Okay, so my sister owns an F510-UA and wanted to upgrade to an SSD. She was previously stuck with the 1TB HDD that came with the laptop. So I opened the laptop up and did some research to learn that it uses the M.2 SATA interface.

I then ordered the Samsung 860 Evo M.2 SATA 512GB SSD. I've seen people put 512GB SSDs into this laptop online and they worked, so I'm confident there's no incompatibility issue.

I put it into the M.2 slot, carefully matching the pins. But it didn't detect it in the bios. Neither did Windows detect it. Worried the SSD was faulty, I put it into my own laptop (Acer Swift 3 - SF314-52G for reference) and the SSD worked flawlessly.

I checked online and it seems to be a common issue with this laptop that the M.2 SSD isn't detected.

So:

* The SSD works

* It is compatible with the interface (SATA)

* BIOS and Windows do not detect it

Should I just update the bios and cross my fingers? It's on version 308 of the Asus BIOS Utility.

Comments

This discussion has been closed.