Wifi adapter won't start (code 10)

Peter_tkPeter_tk Level 1
edited January 28 in ZenBook
  1. System: windows 10 (1909 or clean 20h2)
  2. Battery or AC: both
  3. Model: ux433fa
  4. Frequency of occurrence: constant
  5. Reset OS: yep tried it, clean install / formatted HD
  6. Screenshot or video:

========================

Detailed description:

My intel 9560 adapter stopped working recently. I have reinstalled drivers, reinstalled a clean install of 20h2, rolled back some updates from a few weeks before the problem.


I'm leaning toward this being hardware, except that other users are having similar problems and they are finding it is in fact software related. For instance, my problem sounds a lot like another thread:

I am running bios 310.


Any ideas?

Comments

  • I have the same problems with 9560 adapter(UX333FN 1 year old).

    WIFI (code 10).

    Bluetooth (code 45 - not connected).

    Happens to me after:

    1. restart
    2. wake up
    3. a few minutes after unplugging the power.

    I have tried everything, nothing works.

    Temporary solution is to reset BIOS to defaults.

    I don't know why, because nothing has changed( I compared BIOS before and after), but it works for me.

  • Thanks for the quick reply - I have noticed that this works for others as well, but I haven't been able to get it to work for me.

    I go into BIOS and choose F9 - default and then reboot... is that pretty much it?

    I've just tried a few old BIOS versions (309 and 305) but I didn't see any change.

    I guess I have a UX433FA vs your UX433FN, maybe that makes some difference too.

  • I have UX333FN...

    As far as I know, the differences are screen size and graphic card.


    After F9 you should press F10 to save&exit.

  • I may have found a solution to the problem.


    Warning! This solution worked for me and I do not guarantee it will work for you.

    Using Registry Editor incorrectly can cause serious, system-wide problems that may require you to re-install Windows to correct them. Use this tool at your own risk.

    I am not responsible if anything happens to your PC.


    Before you start, open the advanced power plans settings, check if you have Wireless and USB options.

    if they are missing, as you can see below, you need to edit the registry.


    1. create a new power plan

    2. open registry editor

    3. Navigate to: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\PowerSettings

    4. You will see plenty of weirdly named folders.

    each folder(key), represent an option on the power plan settings, read the description.

    if you want to show this option, you need to set "Attributes" value to 2.

    if you dont have "Attributes" key, add a new DWORD (32bit) Value and named it "Attributes".


    Those are the keys i edited(maybe only one of the is needed, idk):

    2a737441-1930-4402-8d77-b2bebba308a3

        \d4e98f31-5ffe-4ce1-be31-1b38b384c009

    (this key is under the first one, expend his subfoders)


    19cbb8fa-5279-450e-9fac-8a3d5fedd0c1

         \12bbebe6-58d6-4636-95bb-3217ef867c1a


    F15576E8-98B7-4186-B944-EAFA664402D9


    5. Open advanced power plans settings, Now you're supposed to see more options.

    6. Change wireless adapter settings>power saving to best performance.

    7. Change USB>USB3 to minimum saving.

    8. Change wireless standby on battery to available.

  • Thanks again for the quick reply, unfortunately this doesn't fix my problem... bummer.

  • Gave this a try too, but no luck unfortunately. I'm a couple months out of warranty and trying to decide what to do with this, it's all quite disappointing.

    And to rub salt in the wound, I keep getting targeted ads for asus computers bragging of their reliability and "military grade" toughness. ha.

  • Ha Ha! many ASUS ads!

    I bought my laptop October 2019, may warranty ended 2 months ago.

    It's very frustrating!

    Zenbook supposed to be their quality series.


    It turned out I was happy too soon...

    It's better now, but It didn't solve my problem.

    The drivers keeps disappearing after sleep/restart/turning on the computer, but at least I can work continuously between restarts.

    Does your Bluetooth work properly?


    I saw many user here and on other forums around the web, describing problems with the same adapter, AC-9560.

    Post a question on Intel forum, maybe if they will see many people having problams they will do something.

  • No, my bluetooth also stopped working at the same time as my wifi... like you, I thought I was investing in a quality PC.

This discussion has been closed.