My phone is stuck in One-hand Mode Tutorial

YuntianYuntian Level 1
edited September 2020 in ZenFone 6

Please see the video. I have enable Android 10's gesture control as someone said that was the issue. My phone is US version.

https://youtu.be/b8e5JwS2mwo

I first encountered this issue with Version WW-17.1810.1910.63. I have flashed .68's OTA and it doesn't help. I can't really wipe my phone as my phone has 1 irreplacable authenticator.

Best Answer

«1

Comments

  • This seems to be a way to soft-brick your phone.

    If you have gestures enabled, and try to enable one-hand mode for the first time, then you become trapped in the one-hand tutorial, with no way to exit.

    Rebooting does not help.

  • I've never seen this before. What happens if you only press the power button? Will you see the restart button?

    Have you tried the wipe data/factory reset option?

  • OP said he can't really wipe his phone and straight off, you suggested wiping his phone. ?

  • If you happened to have adb turned on you may try fiddling with that, otherwise there isn't much to do other that updating the phone in recovery. It is also not a good idea to grey out the screen in tutorial more and not have the grey out area act as exit, something to bear in mind for other system apps that might have tutorials.

  • Ooop, missed that last sentence ?

    But is the authenticator really irreplaceable? @Yuntian What app are you using?

  • Anyway, I will ask our devs to look into this. If it really is true that you can soft-brick your phone by having one-handed more active while upgrading to Q, then we need to fix this ASAP

  • @Yuntian please give me as much details as possible. A step by step, what you did to get to this point. I can't replicate this on any of my phones so I need to know what you did differently.

  • That's my Blizzard account. I didn't use my real name for the account and for removing authenticator through customer/self service, they only accept photo ID for removal, unlike other 2FA where you can still use your email. If I factory reset my phone then I'll have to sue them to prove I'm the account owner.

    So to replicate my issue, turn on Gesture Navigation from Advanced/Navigation (that new thing in Android 10 that let you swipe on the edge as back button), and then turn on One-hand Mode as the first time ever for tutorial. I believe if you turned on One-hand Mode before then it will not show tutorial anymore. This happened in Version WW-17.1810.1910.63, and persists after I flash .68 delta update package. Please let me know if you still need more information.

  • Press the power button: screen turns off. Press again to see the same stucked screen.

    Hold the power button: you can see the the power menu, but as tutorial layout is above the power menu, I can't tap any button.

    In the video I just hold powe and volume - to force shut down.

  • Are you saying you can use mouse to passthrough the overlay? I already rebooted my phone so I'll have to enter the unlock pattern first. So if your workaround relies on having access to quick action bar then I might be out of luck.

    I'll try it anyway tomorrow. Thanks.

  • I can confirm that this is a bug. It only happens on the first time tutorial though but I had to restart with the power and volume key to get back

  • Confirmed that mouse bypass the tutorial layout. You don't have to drag on the corner, just use it like your finger. I have been able to exit one-hand mode. I also switched back to 3 button navigation and the same tutorial bug occurred again, so the navigation mode may not be the cause.

  • The problem is with the One Hand Mode feature itself. Navigation button has nothing to do with it.

    It's better to it turn off for everyone on Android 10 as i recommend earlier.

  • Thank god we have clever users that can think outside of the box :)

    I tried gesture mode on a phone which I had never used one handed mode on before and it went through the tutorial without any issues. Don't know why this happened to you but good thing it all worked out in the end. Thanks @shiv1g

  • @Yuntian @shiv1g could it be that both of you were using a 3rd party launcher?

  • I'm using Nova Launcher Prime.

    I just tried this with the Asus Launcher and immediately got stuck like earlier in the last step of tutorial.

  • I will send a PM to both of you with instructions on how to log this issue

  • It's been over 2 weeks and not even a hotfix for this huge issue that completely locks you out of your phone? Happened to me a few hours ago and I don't have a OTG cable at hand and I'm sick at home. So I can't go buy one either. At the very least within a week of this issue being discovered you should've implemented something that disables the dumb tutorial or not enable people to access 1 handed mode for the time being. This is shameful. Is there any way to use a mouse without an otg cable like through a PC or maybe just disable 1 handed mode through the PC. Anything?

This discussion has been closed.