Asus TUF A15 FA506IH DTS X ULTRA not working

bbga95bbga95 Level 1
edited September 20 in Others
  1. System: Windows 11 Home
  2. Battery or AC: On Both
  3. Model: Asus TUF A15 FA506IH
  4. Frequency of occurrence: All the time
  5. Reset OS: Yes
  6. Screenshot or video:

========================

Detailed description:

I just recently did a clean install to upgrade to windows 11, and also DTS was working fine for me on windows 10. After the upgrade, it shows up that it's on and working in the DTS x ultra app, but in fact, it's actually not doing anything in both the internal speaker mode or when my headphones are plugged in. Turning it off doesn't make difference in the sound so that proves it's not working, and the sound is low and pretty bad now. I hope someone can help me out as I would hate to go back to windows 10.

Comments

  • Here is an image of what it looks like its on bit its actually not doing anything.

  • @bbga95

    Have you tried the following steps to install?

    https://www.asus.com/supportonly/FA506IH/HelpDesk_Download/#

    DTS:X Ultra UWP

    Must follow below step before install DTS:X Ultra UWP

    1. Download DTS component driver.

    2. Right click on Install_DTSX_Ultra.bat and run as administrator to install driver.

    3. Restart computer.

    4. Go to Microsoft store to install latest version of DTS:X Ultra.


    If you have tried it and it still happens, please provide me your current BIOS version, system version, audio driver version. Also please give me how you played the music and which song is having problems. Sorry for any inconvenience it may be caused. 

  • I am getting this error when trying to install the dts component driver

  • So I managed to fix it by reinstalling my Realtek audio drivers and did everything you said and I am back in the same spot, where nothing I do in the DTS X ULTRA app is making a difference. Also, I have tried using the internal speakers, and the headphone jack and used multiple ways to play audio such as the browser the built-in media players, and 3rd party media players as well but still nothing.



    Bios Version: 3.16

    System Version: Windows 11 Home 21H2

    Audio Driver version: 6.0.9152.1

  • It is also possible for the DTS:X Ultra app to not work properly if there is some corruption associated with it. This can sometimes happen due to the app data that is stored on your computer. In such a case, what you can do is simply reset the app via the Settings window to see if that fixes the issue


    Regards,

    Will

Sign In or Register to comment.