Crackling sound from headphone jack on high volume

Please tell us some basic information before asking for help:

  1. Model Name: ZenFone 9
  2. Firmware Version: WW_32.2030.2030.26
  3. Rooted or not: No
  4. Frequency of Occurrence: Always on maximum volume when music file/stream is loud enough
  5. APP Name & APP Version (If your issue relates to the app): All audio apps


Steps to reproduce:

  1. Connect headphones or amplifier to headphone jack.
  2. Set volume (on the phone!) to maximum.
  3. Play an audio file (e.g. from Deezer, but disable audio normalization).
  4. On louder songs you'll hear audio crackling (occasionally or often - depends on the song).
  5. To boost the effect (audio crackling), use audio equalizer from system settings.


"zf9_music_normal.mp4" - normal music playback (Deezer, no audio normalization, max volume) - audio is distorted (captured by PC's Line-In).

"zf9_music_with_equalizer.mp4" - music playback with equalizer (Deezer, no audio normalization, max volume) - audio is rather distorted (captured by PC's Line-In).


"sine.mp4" - sine wave prepared for testing purposes.

"zf9_sine.mp4" - sine wave played on ZenFone 9 and captured by PC's Line-In.


Audio files has been converted, because it's not possible to upload WAV or FLAC file here.


Screenshot shows the sine wave played by ZenFone 9 and recorded by PC's Line-In. The file was played without equalizer.


Problem doesn't exist on ZenFone 8. Maybe overall volume is higher on ZenFone 9 and it's causing an integer overflow?

Comments

  • Hey @mumei6102!

    Thank you for bringing this to our attention. I've forwarded the issue to the R&D department.

  • @mumei6102

    Sounds like the dac might be overestimating the resistance of your equpiment and push it beyond specs. Since ASUS phones are never neutral it's not surprising that this would happen when pushed to far.

    Could you list the equipment you used to test the sound? I doubt ull experience this with something like a HD 800s or HD650.

  • Hey @Mansi_ASUS , thanks!

    @Danishblunt It can be headphones or analogue amplifier or PC's Line-In or oscilloscope - all have the same issue.


  • Hey @mumei6102, I just heard back from the R&D team. This issue will be addressed in the next FW update.

  • @Mansi_ASUS Hi, thanks, it's working good in 32.2040.2040.23!

Sign In or Register to comment.