camera app zenfone 8

zgredek94zgredek94 Level 1
edited October 1 in ZenFone 8

Model Name: Zenfone 8

Firmware wersion: 31.1010.0411.89, freshly updated

Not rooted


My camera app seems to not having acces to camera. ;(

Screen is simply black when I try to make a picture by it,

BUT in whatsapp everything works fine, front and back camera as well (i can make a picture, send it etc.),

facebook app takes only selfies, when i change to main camera picture freezes, but i can change back and it (selfie) works.

messenger is like facebook, selfie works fine, main freezes, i can go back to selfie and it works

Google lens doesnt work, black picture

i even downloaded snapchat and it works like fb and messenger.


I did everything like they advised on this topic: FAQ/1015523 about camra problems

Reboot, clearing storage, updating firmeware and factory reset doesnt help, in safe mode camera also doesnt work.

I dont know how to "Update the Camera app from Google Play:Then start the Camera ( front & rear camera) again".

In settings i noticed the camera app doesnt show any of its premissions.

Help pls.


Tagged:

Comments

  • Hey, I have the same problem for 2 weeks now. When I launch the camera app I only get a black screen. I can feel the vibrations when changing the camera mode (while having the blackscreen) – strangely I can use PANO without any problem but every other mode will freeze the app again.

    Like OP I tried clearing camera cache & storage without any effect. Neither Save Mode nor Factory reset did any good either.

    I tried different camera apps and only got black screens. Except for WhatsApp camera – for whatever reason this seems to be working.

    Please help - this is super annoying. There was no change in my phone-usage habits the past two weeks. It must be a software problem.

  • If you made a full factory reset and the problem still persists, I doubt it's a software problem and rather a hardware one.

    If I were you, I would try downgrading to Android 11 as a ver last resort before sending it for repair.

  • Hi @Qbert123

    Thank you for reaching out. Please check if your phone will pass the SMMI test,

    Calculator> type ".12345+=">SMMI TEST>Single Test>Wide-angled Camera Capture Test/Tele Camera Capture Test/Front Camera Capture Test

  • jholjhol Level 1

    had the same problem. I couldn´t use the camara only through watsup. Finally took the phone to custumer service where they fixed it.


  • I did try the SMMI test when I was troubleshooting this problem last week and it didn't work. After typing ".12345+=" into the calculator nothing happened.

    Yesterday I gave my phone to customer service. In addition to the camera issue there was also a small area on the screen (below left of the finger print sensor) that had a light blue discoloration.

    I hope it will be fixed for good now.

  • Thread automatically closed due to inactivity. If the reported issue has not been resolved or you require further assistance from one of our moderators, please create a new thread and we will be with you shortly.

This discussion has been closed.