Need help with fingerprint

dixingodixingo Level 1
edited July 31 in ROG Phone 5

Please tell us some basic information before asking for help:

  1. Model Name:Rog Phone 5s
  2. Firmware Version: 31.0810.1226.92
  3. Rooted or not: not
  4. Frequency of Occurrence: permanent
  5. APP Name & APP Version (If your issue relates to the app): fingerprint sensor

In addition to information above, please also provide as much details as you can, e.g., using scenario, what troubleshooting you've already done, screenshot, etc.

========================================

I broke the screen of my Rog Phone 5s so I found a cheap Rog Phone 5 with a dead motherboard. I replaced the dead motherboard with the one from the phone with the broken display. Everything works perfectly apart from the fingerprint sensor. the sensor is connected and the test in the test menu is passing. The problem appears when I try to add a fingerprint - no matter how I place my finger it's not registered. The white dot lights up, but the sensor doesn't register my fingerprint. What can I do to make it work again?

Comments

  • FunBike31FunBike31 Level 4

    31.0810.1226.*"92"*!!! is there a new firmware?


    I think a recalibration is needed, you need a tool and software, the software is from December 2021, I have no idea if it works with Android 12

    Here is an example of the tool and a discussion on XDA

    Otherwise if you have an ASUS repairer nearby it's fast and cheap

    https://uk.aliexpress.com/item/1005003640410708.html?gatewayAdapt=glo2eng

    https://forum.xda-developers.com/t/asus-rog-3-rog-5-rog-5s-fix-fingerprint.4355499/

  • dixingodixingo Level 1

    I ordered the tool, but while I'm waiting I decided to try to calibrate using the app and two pieces of paper - I know this is not the correct way, but at least I want to check if I can get any feedback from the sensor. So after calibration pass it's all the same - my fingerprint is not registered at all. I tried downgrading to Android 11 and there I'm getting an error saying Fingerprint registration failed immediately after I try to register a fingerprint. I also tried some apps which are supposed to check if the fingerprint sensor is working - one of them is crashing immediately and another is saying that the sensor is currently in use. Can I get someone from Asus to clarify if the calibration method is the solution, for which firmware this method is working and is there a way to downgrade to this version?

  • FunBike31FunBike31 Level 4

    This part seems to carry the same reference between the 5 and 5s, the problem is not the driver.

    While waiting for you to have an answer from Asus, do you remember if you had reached the maximum (5) before the breakage of the screen?

  • dixingodixingo Level 1

    Judging from the internals of the two phones everything inside is the same apart from the mainboard. If I remember correctly I had only 3 or 4. Is there a relation? If the fingerprint is passing the test in .12345+= could I consider that hardware is ok and it's a software issue?


    Our local Asus repair shop is a contractor which I think will not even try to solve the issue as soon as they understand that something was done with the phone.

  • Hi dixingo

    For your issue, we will recommend that you could visit the repair center for further inspection. Since you replace the LCD yourself, the device will lose the warranty. The inspection and repair will under a chargeable basis.

    For the repair center near you, please refer to the following link.

    Thank you

  • Thread automatically closed due to inactivity. If the reported issue has not been resolved or you require further assistance from one of our moderators, please create a new thread and we will be with you shortly.

This discussion has been closed.