Wireless can no longer be turned on

AlastorAlastor Level 1
edited March 10 in ROG Phone 3

Please tell us some basic information before asking for help: Phone updated automatically overnight and now I cannot get the Wifi Function turned on at ALL

When I try to turn it on, it just doesn't do anything at all. It is also not showing me any Hardware MAC address on it

I just done a network, and then a factory reset on this phone and the issue still remains. The hell happened with the update! I do not use a sim card as this is a secondary phone so having wifi is extremely important!

  1. Model Name: Asus ROG Phone 3
  2. Firmware Version: 18.0410.2201.192
  3. Rooted or not: No Root
  4. Frequency of Occurrence: Constant
  5. APP Name & APP Version (If your issue relates to the app): - Android 11

In addition to information above, please also provide as much details as you can, e.g., using scenario, what troubleshooting you've already done, screenshot, etc.

========================================

If anyone has managed to fix this issue, even if it is via installing a CFW please let me know as I can do that if need be due to the phone not being under warranty. (Frankly this should be fixed even if out of warranty because the cause is the shitty update that was auto-installed if you ask me)

Comments

  • ronald1985ronald1985 127.0.0.1 Level 5

    Even though you have factory reset, I suspect going into safe mode doesn't work either.

    Can you go into calculator and type in .12345+= and perform single test followed by WiFi Test.

    The suggestion is to visit your local Asus service centre anyhow but the calculator test will determine of its a hardware failure.

  • Probably broken driver during update.

  • AlastorAlastor Level 1
    edited February 6

    I would, if they didn't shut down the only Asus service center in Australia NSW. Next closest is in another state altogether. Only recourse at the moment is to deal with support online which I have already sent an message.

    The other problem is the broken glass display and being out of warranty. I don't mind the display as this is a secondary phone but I am NOT paying for that to be fix when the issue is to do with a separate problem entirely...

    Oh and the wifi test doesn't work as it only works when it is connected to wifi but I can't even get there. So it fails all the time right now

  • Finally solved the problem myself. Be warned some of the stuff below might get a bit technical.

    As I couldn't really depend on Asus support due to my circumstances, I decided to try a custom firmware but luckily I didn't need to get that far. Do note though you WILL need to unlock the bootloader which you can do via Asus official support page which has an app for that. This will reset your phone, and also requires a internet connection which I accomplished by putting in a simcard temporary.

    Following a guide on the XDA Forums here I was able to install the TWRP recovery onto the phone

    "Google [RECOVERY][OFFICIAL] TWRP for ASUS ROG Phone 3 because I can't post links"

    One important thing to note was that I needed to put the USB into the SIDE port in order for Fastboot to register properly. This took me like 2 days to figure out cause WHY I DON'T GET IT.

    Once TWRP was installed, I was able to perform a factory reset from there via Wipe, sliding factory reset option at the bottom. And restarted the phone. The plan was to try to install a CFW or downgrade from there. Luckily though, the wifi started operating again after that!

    So I am now leaving it as is for now. This is just a note for any one that got the same issue for future reference.

This discussion has been closed.