Need help pls. I'm not really tech savvy.

pervinjocsonpervinjocson Level 1
edited July 13 in ROG Phone 2

Been having problems with this now. Please watch the attached recording. It happens most of the time when I use the side port when I'm charging. Tried different cables and chargers but it doesn't seem to go away. Even with the charger and cable that comes with it. On a good day this doesn't happen but most of the time it does. Even if I attach the fan attachment it still pops up. It still charges but it's really annoying.

Comments

  • ronald1985ronald1985 127.0.0.1 Level 5

    Before doing any of the below, please take backups of important data.

    Does it happen in Safe Mode?

    To get to safe mode, press and hold the power button. Press and hold the shut down button and then you will be asked to go into safe mode. If it doesn't happen in safe mode, then I would recommending factory reset.

    If the issue still happens, factory reset anyway and then please visit service centre. If the issue doesn't happen all the time, ensure you take the recordings.

  • @pervinjocson As Ronald suggests, boot into safe mode (long-press the 'shut down' button and you will be asked to do so). If the issue goes away, backup your personal data and perform a factory reset.

    If the issue persists, I'd like to get a device log from you so that our team can take a closer look at what's happening.

  • It's still happening. I while ago it wasn't. I was charging using the side port then unplugged it because I had to go outside. When I got back and plugged it back again it happened again. Then I switched to safe mode but it didn't stop. I just turned off my phone then charged it to full so I don't have to deal with it.

  • ronald1985ronald1985 127.0.0.1 Level 5

    If you are still facing the issue while in safe mode, then you should visit the service centre when you can.

    While you can't see the issue when the phone is off, that random popup maybe indicating something is wrong with your phone from the inside. Safe mode would of indicated if it was a software issue.

  • Crap I was hoping it was a software issue. At least I can do something about it. Question. If my phone is still under warranty, will I still have to pay for fixing it? Money is a bit tight since its the pandemic.

  • I would imagine since it's still under warranty you should be covered. Take a TON of pictures documenting absolutely everything before you send it out. No such thing as too many pictures. Red magic water damaged a device of mine at a service center and blamed me because my dark colored background didn't immediately show the damaged they caused. So make sure everything is clearly visible in the chance something happens at the service center you can prove it wasn't caused by you

  • Thanks for the help guys. It seemed to have fixed itself somehow. It's not happening anymore for the past few days. Hope it stays that way though haha. Anyway, cheers to guys for being active! 😁👍

  • Sorry to bug you guys again but I semm to notice that every time I use the side port to charge, my mobile data fluctuates a lot. Is that a common issue for ROG2? But when I'm using the bottom port it doesn't. Kind of annoying when playing online haha

  • ronald1985ronald1985 127.0.0.1 Level 5

    With regards to your initial issue, I think you need to let your device cool down after it is being charged.

    With regards to your issue on internet fluctuates, what do you mean? What app is it this doing it on? Can you show a video of the issue with side port and bottom port?

    The easiest way is to do a speed test on both ports.

This discussion has been closed.