Flip camera toolbar not appearing?

The flip camera toolbar doesn't appear anymore when I open the camera. It is enabled in settings, I've tried disabling and enabling it with and without restarts along the way and it still won't appear. The quick angle widget does appear in the camera app but not the flip camera toolbar. Is there another setting I need to change? I found it quite useful in the past.


Comments

  • TagionTagion Level 2
    edited March 3

    It seems like you have a case on that can hold the flip camera in place (for example the included black case)

    If nothing is blocking the flip camera, you can disable ASUS cover mode

  • cvonvcvonv Level 2
    edited March 3

    You might have the gesture control for it enabled instead of the icon.

    I have gesture control on (swipe from bottom right) and it comes up. The problem now is that I can't switch to icon mode anymore. Like I can select icon mode but it will never show up. So I can only use gesture to bring it up. 🤷🏻‍♂️

  • TagionTagion Level 2

    I think this setting is only for third party apps though. His stock camera app is indicating that the ASUS cover mode blocks the flip camera

  • cvonvcvonv Level 2

    Fair point. Icon is showing it's blocked.

    But yeah my flip icon doesn't work in 3rd party apps lol

  • dartsdarts Level 1

    The issue is there regardless of the camera cover state.

    I have it set to 'Tap Icon', changing it to the 'Swipe Gesture' makes no difference, the icon isn't there.

    I can still adjust the angle in the main camera app using the volume button but the icon is gone. I used to use it in third party apps too so it is a bit inconvenient.

  • dartsdarts Level 1

    Thank you that is quite useful.

    The issue isn't just the camera app, the toolbar used to allow me to move the camera when the torch was on or in third party camera apps. I suppose I'll just deal with it. Shame I really liked the feature.

  • cvonvcvonv Level 2
    edited March 29

    Bringing this back up. I've updated to A11 and yeah icon mode doesn't work at all for me still. I have tried clearing the storage for the camera app and still the toolbar icon won't come up. Only swipe gesture works.

    A factory reset will probably fix it but that's quite a hassle to do.

  • dartsdarts Level 1

    It's still missing for me. Regardless of icon or gesture mode.

    Contacted support and they were utterly unhelpful, telling me to perform a factory reset which would require 2fa resets for a bunch of accounts.

  • dartsdarts Level 1

    After switching from gesture navigation to button navigation, booting into safe mode, toggling the toolbar, rebooting and changing the navigation back to gesture-based: the flip toolbar now appears in some 3rd party apps (signal, gcam, threema) and when the flashlight is on. Which largely solves my problem.

    It doesn't appear when the default camera app is used or in apps that make OS requests to take a picture/record media (see: https://developer.android.com/reference/android/provider/MediaStore#ACTION_IMAGE_CAPTURE for a deep dive) as opposed to apps implementing their own interface with the camera2 Api

  • cvonvcvonv Level 2
    edited April 2

    Your method didn't work for me. However, I have figured out that it's the "Accessibility Menu" that is the culprit because it appears as a fourth button in the navigation bar which is normally where the Flip Toolbar icon is. If I disable that, then the Flip Toolbar icon now appears in both system navigation styles.

  • I have a similar bit not same issue, i opened a thread but the problem has never been fixed : https://zentalk.asus.com/en/discussion/39592/flip-camera-tool-shortcut-does-not-work

  • dartsdarts Level 1

    Does the issue persist if system navigation is set to icon rather than gesture?

  • Nope, it works when it is set to icon button.

Sign In or Register to comment.