ASUS TUF GAMING 505GT - Video Problem : HELP NEEDED!

KC MKC M Level 1
edited March 20 in Others
  1. System: Windows 10 Home
  2. Battery or AC: AC
  3. Model: ASUS TUF GAMING 505GT
  4. Frequency of occurrence: once every week
  5. Reset OS: Done, it just reduced frequency from 3-5x a week to once a week - LCD was also replaced.
  6. Screenshot or video: Can't send video as apparently I have to be a member for a while to be able to send link. I have attached a picture though.

========================

Detailed description:

I have this weird Video problem whenever I play videos using Media Players or stream video using NetFlix or Youtube, there is a chance that the video would freeze with dancing boxes and eerie static noise with HardReset as the only solution. I have tried the following:

  1. Installed all windows update
  2. Installed all needed ASUS updates (Firmware and Software)
  3. Reimage the Computer
  4. Replaced the LCD from the manufacturer's warranty
  5. Reimage the computer again


Same thing. The only relief is with everything that I have done is that it happens once a week now instead of the 3-5x a week. I love this laptop and it is just sad to see an ASUS TUF Gaming series laptop with this type of problem that cannot be fixed by local ASUS certified technicians. I have never encountered anything like this before and this is the first time I bought an ASUS brand. Can someone help me fix this? Thanks a bunch!


Comments

  • this is really worst problem.

    wil you able to use different browsers like Microsoft Chromium Edge browser or Google Enterprise Chrome Browser or Mozilla Firefox browser .

    also try to use linux live bootable os, and play youtube videos in firefox browser.

    sometimes in Windows , playing of videos in browsers gets weird , so we need to enable or disable use hardware acceleration of gpu In browser settings.

  • KC MKC M Level 1

    ohhh. so this is not a hardware or laptop problem but an OS problem and getting the hardware acceleration enabled or disabled may resolve it, huh? Let me try it and I'll update this thread if this keeps happening. Thanks for the answer! :)

  • KC MKC M Level 1

    So update on the issue, Using a different program that does not have hardware acceleration. This happened again. This only happens if I am using the other GPU, NVIDIA GEFORCE GTX 1650 Display Driver. Whenever I use the default intel UHD Graphics 630, this doees not happen. What's the point of having another GPU Nvidia hardware if it is incompatible with the device. Such a shame.

  • It must be a installed driver problem..

    for your nvidia graphics card, there are two types of drivers are available in nvidia official website.

    1. Game Ready driver 461.40

    2. Studio driver 461.40

    so install one by one, and recheck the problems again.

  • Hello KC,

    Do you have another monitor you can connect to ?

    If so, does the external monitor have the same issue?

    Thank you.

This discussion has been closed.