Installing Stock ROM Not Working?

elias888elias888 Level 1
edited September 2020 in ZenFone Max Pro Series


  1. Model Name: Zenfone Max Pro M2 ASUS_X01BDA (ZB631KL-4D103TW)
  2. Firmware Version: OPM1.WW_Phone-15.2016.1902.192-20190226
  3. Rooted or not: not rooted, bootloader unlocked - yes
  4. Frequency of Occurrence: Always
  5. APP Name & APP Version (If your issue relates to the app): Can't re-install stock ROM

========================================

A. I tried installing LineageOS tonight: booted into TWRP recovery, wiped everything, tried to sideload LineageOS but said my firmware was too old (Said I needed at least 16.2017.1905.065)

B. Now I'm trying to go back to stock android ROM, so I can update the firmware.

C. Downloaded the file UL-ASUS_X01BD-WW-16.2017.2005.092-user.zip from ASUS website.

D. Booted into TWRP, tried to use 'adb sideload UL-ASUS_X01BD-WW-16.2017.2005.092-user.zip' to load stock ROM but I get the error:

"E3004: This package is for "ASUS_X01BD" devices: this is a "X01BD".

I also tried puting the zip file into / directory, and rebooting. That didn't work.

So now I have a phone with no operating system, stuck in fastboot/TWRP.

====

Any suggestions how to get stock ROM back on the Zenphone? Thank you.

Comments

  • AkashaAkasha Level 1

    Just press on Install in TWRP recovery and select a TWRP Flashable File (The Official file from Asus site won't work as it's only intended for stock recovery)

    I am sharing you a link to the full TWRP Flashable firmware file found in Telegram:

    https://telegra.ph/Download-links-of-stock-ROM-both-stock-recovery-and-TWRP-flashable-links-03-30

  • Ok thank you. In my haste to fix the problem, I couldn't sleep and did something foolish though, I lost TWRP.

    I flashed boot.img, system.img, recovery.img, and cache.img with fastboot (fastboot flash boot boot.img etc).

    So now I can't boot into Android, but I do have stock Android recovery available.

    Going by what you said, now I can use the official file from ASUS (UL-ASUS_X01BD-WW-16.2017.2005.092-user.zip), put that on an SD card and then "apply update from external storage", correct?


    Also, thanks for your suggestions so far! I'm new at this ROM stuff.

  • kprsntkprsnt Level 1

    Yes, u can flash

    But u ended up with stock ROM


    Just flash twrp from fastboot again then flash lineage

    Flash firmware from this link, this zip is enough to flash lineage

  • kprsntkprsnt Level 1

    I'm unable to paste links

    But u can find link in google

    Search x01bd firmware 92 sourceforge in google (click on first link)


    Or join telegram group maxpro m2 updates


  • kprsntkprsnt Level 1

    If want no customization then try PA ROM

  • elias888elias888 Level 1
    edited June 2020

    Ok, but I don't think the stock ROM flashing worked, or I would be able to boot into Android. It seems to hang at the ASUS logo.

    So then I hold Volume Down + Power but that brings me to the recovery screen. Not sure how I can get to Fastboot mode right now.

    Recovery mode has these options:

    reboot system now

    reboot to bootloader

    apply update from ADB

    wipe data/factory reset

    wipe cache partition

    apply update from external storage

    view recovery logs

    power off

    root integrity check


    Anyways, I'll try to get into fastboot again, and then flash that TWRP recovery firmware 92.

    Thank you for all your suggestions.

  • kprsntkprsnt Level 1
    edited June 2020

    Hold Volume up+ power button to enter fastboot mode

  • Ha easy. Giving you lots of "Likes" now!

    You are very helpful. Thanks for helping me through this. Hope this thread helps others too. I'll update later how it goes tonight.

  • Update!

    1. I got into TWRP fastboot, tried to adb sideload Lineage right away but still said I didn't have the right firmware. In Asus recovery it said I had PKQ1.16.2017.1910_071-20190920
    2. So I sideloaded a stock ROM and it worked!
    3. Looking in Settings - System - About Phone and it says i have build number: PKQ1.WW_Phone-16.2017.2005.092-20200518. It seems I should be good to install Lineage OS now. I just have to work up the courage to try again :D
  • As per XDA developer guide , When you flash stock ROM zip file directly from ASUS site , TWRP or any recovery will get replaced with stock one. In XDA developer fourm there are custom Recovery flashable zip available for 72 73 and 75 versions. Even there are steps provided for installation of firmware from ASUS official zip file with out loosing custom recovery.


    I am using Havoc Os with 424 latest beta firmware. It's working smoothly.

    My another suggestion.

    At present Android 10 based lineage OS is not available officially. But unofficial ROM is there in XDA fourm. Meanwhile you can use Android 9 official version

    If you need offical 10 based ROM then you can try Pixel experience for pure UI Havoc OS for high customisation , Stock mod for UI near to stock rom with better performance.

  • cool. thanks for the suggestion.

    I went back to install LineageOS 16.0 and it worked! Success!

  • kprsntkprsnt Level 1

    Try Paranoid android rom u will definitely love it if u don't want any customisation


    Unofficial lineage 17.1 by rk also too good

  • Can you give a good link for anyone starting to shift to custom rom from stock rom who hasn't used any tool before?

  • XDA developer fourm is the best platform to learn about how to use custom ROM

    Unlocking bootloader , installing recovery , installing new rom , custom Google apps , Rooting( If needed) etc you can get any information from there

  • I like ROM which has no GApps included. It will consume less of our data for download. HAVOC ROM size is about 700 mb and I am installing Gapps manually. That's why I preferred it. Monthly updates and best customised rom especially Smart charging makes it my most favourite

This discussion has been closed.