Phone (Zenfone 6 ZS630KL) keeps booting into csc fastboot mode

YavychYavych Level 1
edited September 2020 in ZenFone 6

Hello. Today, my wife's phone stopped responding to anything out of blue. I did a forced reboot (Vol down + power) and it rebooted and worked fine for a bit. Seeing as Android 10 was out, I dled fota file and flashed it via recovery from SD card, like I usually do. It flashed successfully and then rebooted. Once it booted, after a few seconds it hanged and became unresponsive again. Forced reboot once again, except this time it booted into a fastboot mode on its own and here lies there problem:

- going through an option to get into recovery mode doesn't help as it goes back into fastboot mode again

- rebooting through cmd doesn't help either

- pressing start just returns to fastboot mode - shutting it down through an option in fastboot and then turning it on still yields the same result.

Basically, whenever phone turns on, it goes into a fastboot mode whether you want it or not.

Seems like update failed to flash into slot B

(bootloader) has-slot:system:yes
(bootloader) current-slot:a
(bootloader) has-slot:boot:yes
(bootloader) slot-retry-count:b:6
(bootloader) slot-unbootable:b:yes
(bootloader) slot-successful:b:yes
(bootloader) slot-retry-count:a:7
(bootloader) slot-unbootable:a:no
(bootloader) slot-successful:a:yes
(bootloader) slot-count:2

What can I do about this?

Best Answer

  • YavychYavych Level 1
    edited November 2019 Accepted Answer

    Okay, so I fixed it.

    I flashed service/raw fw through fastboot, commenting out userdata formatting part of the flashall_aft script (fastboot -w). After this, I was able to access recovery mode. In recovery mode, I flashed build 16.1220.1909.194 and then 17.1810.1910.63 from my SD card and phone came alive, while retaining all the data.

    Perhaps, this information will help someone who will encounter the same situation.

Comments


  • As a layman with very minimal experience flashing Android phones, I would recommend contacting your regional ASUS Support for a repair.

    Before that, I did a quick Google search and someone who had a similar issue apparently was able to stop the fastboot cycle by removing the SD card. Is that an option or have you already removed it?

  • Hello, contacting local asus support is not an option.

    Removing SD card doesn't anyhow help either.

    I'd honestly try to just flash fw through fastboot into slot B, alas, that's not possible because device is locked.

  • That's why I'm thinking Support is your only option here. If you can't do anything on the software side because the device is locked in a loop, Support might need to arrange a swap for you.

  • YavychYavych Level 1
    edited November 2019

    I can't do anything on a software side mostly because phone is factory locked, not because it's in a loop. If I could unlock bootloader through fastboot, I'd be able to flash FW into a slot B

  • cobbencobben Level 2
    edited November 2019

    Can you copy the FOTA File to the phone while it is in fastboot mode?

    If you can, try just rebooting it then - it might find the file and try to install it all on its own.

  • It's in the root of SD card which phone usually detects when it's on. I can't copy it to the internal storage while it's in a fastboot mode

  • Well, issue has come back, again, out of blue. Phone was lying on the table overnight and in the morning became unresponsive. This time, however, force reboot doesn't help. Device is stuck in QDLoader  mode. Perhaps it's one of those that had a defective mother board and should be replaced by ASUS? Is there any ASUS support center that handles these phones in Ukraine?

  • ColorSageColorSage Level 3
    edited November 2019

    I would suggest installing a zip through recovery. You don't need unlocked bootloader for that. If your phone's bricked again and has problems with bootloader you will need RMA though

  • While the phone is in QDLoader  mode, both recovery and fastboot are inaccessible

This discussion has been closed.