cancel
Showing results for 
Search instead for 
Did you mean: 

ROG Phone 7 - Hotspot & tethering not working/no internet shared

krystianhoro
Star II

Hi Guys,

I am experiencing an odd issue with the hotspot not sharing the internet connection by Wi-Fi or USB Tethering.

USB worked for 3 minutes when I initially connected the phone to my PC via the USB-C cable but it randomly disconnected and I was unable to get back the connection with subsequent attempts.

With the Wi-Fi I tried connecting my other Android phone, laptop & PC all resulted in the same outcome where all devices got connected but did not get any internet. Switching the SIM to an older phone hotspot worked flawlessly.

PC did get the IP address and I could ping the phone but pinging the 8.8.8.8 just timed out.

Wi-Fi hotspot settings:
Hide SSID - No
Security WPA2-Personal - Tried None or WPA2/WPA3-Personal no difference
Type of Wi-Fi hotspot - Wi-Fi 5 (2.4 GHz or 5GHz)
AP Band - 2.4 GHz Band

Network & internet
Tried Private DNS - Off/Automatic no difference

System:
Android 13
Latest update: 33.0820.0810.241

10 REPLIES 10

kmcmurtrie
Rising Star I

The side port on my phone frequently gets dirty somehow and becomes unreliable.  I clean it with a flux brush and it works again.

Also watch out for junk USB cables.  Pretty much all the computer accessories in big online stores (Amazon, Wallmart, AliExpress/etc.) are worthless.  Bots there continuously generate fake brand names and write fake reviews to avoid anything building up a bad reputation.  Buy from a store that carefully selects which items it sells.

krystianhoro
Star II

Hi @Mattias_ASUS any update from the dev team on this issue?

Just to highlight it only happens with sharing Mobile Data. Sharing Wi-Fi works as expected.

Hi @krystianhoro they are still looking into this, will let you know when I get an update 🙂

krystianhoro
Star II

Hi @Mattias_ASUS 

Any update, it's been a while would be good to know if this is an isolated case or a wider problem.

I confirmed with Vodafone that everything is configured correctly and there shouldn't be anything from their side blocking the internet sharing.

Hi @krystianhoro 
I got a reply from the dev team and everything seems to be working normally so it might be a configuration issue.
They suggest to try deleting the Vodafone MISP APN and see it you can make it the default type APN