Showing results for 
Search instead for 
Did you mean: 

X470i gaming motherboard M2 nvme ssd transfer speed issues

Star I

Good morning, I am struggling with my new hard drive to get it to link at the proper speeds, and now im concerned it is not supported. It is installed in the M2_1 slot on the front of the motherboard beneath the heat shield. The drive is a teamgroup mp34 4.0tb drive (TM8FP4004T0C101). My transfer speeds are slower than they should be, im getting about 900/800 when I should see up to 3500/2900.


I have a ryzen 5800x3d processor installed. When I look in Crystaldisk info it shows "PCIe 1.0 x4 | PCIe 3.0 x4" 

This leads me to believe even though it detects the drive can do pcie 3 x4, its only linking at pcie 1.0 x4 thereby limiting my speeds. I have tried playing with the bios settings, to force gen 3 support but nothing seems to be working. 

Does this motherboard not support faster speeds with my setup? I also have a Radeon RX7800gt installed.


Any help greatly appreciated, its driving me nuts.






Hello, @DeOrgy 

May I ask if you have tried updating the relevant drivers and BIOS to the latest versions?
According to the official website of the ROG STRIX X470-I GAMING, we released the latest BIOS 5201 on September 6th.
We would recommend that you update the BIOS first, clearing the CMOS, and then confirm again under the default BIOS settings.
If the read/write speed issue persists after updating the BIOS, please share the following information for further troubleshooting assistance:
- the current BIOS version and the images of the setting in BIOS, or whether it is the default
- the brand and model name of the GPU, RAM(part number as well), and PSU currently installed
- the OS version, OS  build, and the relevant driver version
- the result of the CrystalDiskInfo test for SSD read/write speed (it's not recommended to run other software or games in the background at this time) If possible, please provide a video of the test.

Thank you.