USB connection to pc not working - Phone is not detecting USB connection

luizhcgoncalvesluizhcgoncalves Level 1
edited September 2020 in ZenFone 4 Series

Please tell us some basic information before asking for help:

  1. Model Name: ASUS_Z01KD Asus Zenfone 4 (ZE554KL)
  2. Firmware Version: Can't find it but I'll attach prints of all the about and relevant screens.
  3. Rooted or not: No
  4. Frequency of Occurrence: Current

In addition to information above, please also provide as much details as you can, e.g., using scenario, what troubleshooting you've already done, screenshot, etc.


I'm trying to connect my phone to my pc but the device itself is not detecting the USB cable properly.

I'm using the OEM Cable that came with the phone, still in perfect conditions and usually only used for charging, but also tried on a second one I have. Device charges normally without any troubles, but when connected to PC I don't get the USB Tethering option (it says that USB it not connected), and the computer itself doesn't detect it whatsoever, so I can't access the device files.

Tried on Windows 7 and 10 and Linux Ubuntu 18.04 and 15.04.

I tried looking for it on the device manager but can't seen to find it. USB Configuration is set to MTP and USB debugging is off. Tried turning the device off and leaving it be for a while and then back on, but still no result.

Any other option to try and fix the issue?


This discussion has been closed.