ROG 2 White Screen and back logo flashing red

2»

Comments

  • @davidsquires56 Had a hardware fault and has been directed to contact a repair center.

    At this point, that is my recommendation for you as well @amangond1998 .

  • @caesar_kojak , I can check on the status of your repair if you're located in the US or Canada.

  • @LP_ASUS

    No service center in Dubai for Asus Mobiles. Only the seller looked into it and they could only say it's a screen responsiveness and attachment issues, both both hardware and software together, but since I'm not the only one here, is it a specific batch that was produced faulty? Anyways they gave me a refund and I bought another one had for 2 days now and so far no issues on the screen. But Im sure the phone has to be tested for at least 2 weeks since that's when the problem started showing in the first phone.

    The build is WW.... 1910.64 on both phones (old and new one)

    First faulty phone SN : KBAIKN05B143LLX

    New phone SN: KBAIKN05B455FW5

    Maybe worth checking that batch of faulty Serial phone numbers of everyone here..

    Hope the new phone continues without issues..

    Let us know what you think

  • That sounds ideal, and like a really nice reseller! I'm happy to hear that you got a replacement without much hassle.

    Fingers crossed that this phone doesn't repeat the issue. If it does, let us know and we'll be here to support you as best we can. It is more complicated when your region doesn't have a repair center available.

This discussion has been closed.