achaltrehan5achaltrehan5 Level 1
edited August 29 in ROG Phone 3

Please tell us some basic information before asking for help:

  1. Model Name: Asus ROG Phone 3
  2. Firmware Version: 17.0823.2104.147
  3. Rooted or not: No
  4. Frequency of Occurrence: First Time
  5. APP Name & APP Version (If your issue relates to the app): NA

In addition to information above, please also provide as much details as you can, e.g., using scenario, what troubleshooting you've already done, screenshot, etc.


I have a habit of switching off my phone for a while, once a week, to clear cache and close background apps. Tonight I did it again. And when I tried to switch it on, it didn't. DAMN, NOTHING IS WORKING. My phone battery was above 80%. Still, I tried connecting to the charger and guess what? - NO LED BLINKING.

It seems dead. I sincerely want to know what could be the reason? Now I can't even decide when to switch off my own phone? As I mentioned earlier, it was working fine.

This is my worst experience with a flagship phone.

First-year itself, I experience, screen breakage after such a minor fall, then I experienced a right-side air trigger issue. As soon as the warranty expired, I noticed a left-side air trigger issue. And now this.... I am fed up. Nearest service station is around 55-60 kms from my place. And then they will send it to place which is 200+ Kms away from my place. What will I do for next 10-15 days?




  • I am awaiting a reply from your side sir/ma'am?

  • excavation5excavation5 Level 2
    edited June 30

    Here all the posts are for rog phone 5 there is a another place in this forum only for rog phone 3

    Also you can get your SOLID SOLUTION for you phone only in service here is a forum you make a post and if someone can help you he will but some problems are for service and no one here can help you .... i also have a problem whit my rog phone 5 no one from here help me becouse it was a HARDWARE problem and i send it to warranty now they will change my motherboard

  • Hi achaltrehan5,

    Please share your details in the personal inbox.

  • @ARP_ASUS how can I connect to you in the personal inbox? Please help

  • I am facing the same issue. My phone also turned off for no reason and the charging led is also not working.

  • Tried to call the service centre but no one is responding. Very disappointed didn’t expect this kind of service from ASUS

    1. Press and hold the Power button for 10 seconds to force shut down the device, then press the Power button again to restart the device. 2. If you cannot normally enter the system after you restart the device, send your device to a local service center for further examination and check.



  • Thread automatically closed due to inactivity. If the reported issue has not been resolved or you require further assistance from one of our moderators, please create a new thread and we will be with you shortly.

This discussion has been closed.