ASUS may have just bricked my wifes phone. Stuck on ASUS boot screen. NOW DEAD

homerlovesbeershomerlovesbeers Level 1
edited November 2020 in ZenFone 6

Hi all,

I'd appreciate it if ASUS support can address my phone failing under warranty. Please see my issues.

I woke up around 1am on the 18th Sep to a glow from my wifes Zenfone 6. Wondering why I looked at her screen to find the ASUS logo glowing fully bright like It does upon start up.

Thinking this is odd I tried rebooting it but every single button is unresponsive. I tried holding the power button down for around 30 secs, nothing.

My wife wakes up wondering what I'm doing then tells me her phone updated around 11am on the 17th (so the previous day).

So it appears the ASUS pushed update has potentially stuffed her phone?

Her phone is a totally stock ASUS Zenfone 6.

I waited for the battery to die and after charging the phone powered up. It lasted a few hours before suddenly shutting itself down when the wife was changing settings to pull the time from the network.

Now dead as a brick. Charge light no longer lights. Totally unresponsive. No amount of power button/volume button combination or time will do anything to make it work again.

PC also doesn't recognize the phone when plugged in to the USB port.

Pretty pissed off as it's 1 year and 16 days old and has already been sent back to ASUS to have the charge port fixed after it stopped working. Sounds like another failed main motherboard potentially?

I do not know what to do now except push for a repair by ASUS.




This discussion has been closed.