After update 31.1010.0411.138 (2022-10-05) Location Service don't stop

After update my ZenFone 8 to version 31.1010.0411.138 (2022-10-05) the Location Service don't stop.

It is always showing the location icon on top bar and alerting form an app cosuming much battery.

Looking the battery alert detais it shows the app Location Services.

If I turn off the the Location and turn on, it stay for a while off, but when some app uses the Location when the app is closed the Location keep on.

Tagged:
«1

Comments

  • I've got this exact problem too.

    I"solved" it for now.

    It's caused by night light, just set a custom schedule for it, do not use the sunrise/sunset schedule.


  • Of course, it's a bug that should be solved, I have no idea what the cause of it may be.

    @Gustav_ASUS @Irene2_ASUS @CH_ASUS @Christine_ASUS

  • I had the same problem and only solution was turn off night light by sunset/sunrise. Thanks @Rokcy98

  • Same problem here. Any solution?

  • Thanks guys! I confirm the bug is in the scheduled night light. Disable it and problem solved. Ok as workaround but will be good to have a fix on next update. Tks

  • Hello everyone,

    We aren't able to replicate this issue. Can you all help us out by providing a log:

    Please follow the below steps to enable the built-in log tool (Bug reporter).

    1.  Open “Calculator APP”

    2.  Enter “.19595+=”

    3.  Select the Log type "Location"

    4.  After your selection the log tool will exit so you can duplicate the issue.

    5.  Navigate back to the log tool via calculator and Tap "FINISH AND SHARE".

    6. It takes several minutes for the log to generate. You can exit and do other stuff in the meantime. A silent notification will tell you once the process is done. Tap the notification and then the share button to upload the file to Google Drive and share the link with a moderator. Just make sure to change the permission first so that everyone with the link has permission to view it.

    Thank you!

  • @Karen_ASUS I started the log with night light set to manual, after that I switched to sunrise/sunset (that gives us the problem), after that I set to manual again and finished the log.

    https://drive.google.com/file/d/1BP1yeB43Ze8NbGW6cbkZVE8l-I1BNxRD/view?usp=drivesdk

  • Thank you so much @Rokcy98 and @vinko063. I'll keep you posted here.

  • Hi,

    I had the same issue. I did a factory reset without any luck. Turning off the scheduled night light solved it for me too.

    Just wish I read this here earlier...

  • MyxMyx Level 1

    I also found a geolocation problem in the weather app. To fix the problem, turn off location detection in the background.

  • Thanks a lot for your hint, @Rokcy98 ! After the latest update, I had the same issue on my Zenfone 9 - the cause seems to be the same as on the Zenfone 8.

    In my case, it was not the "night light" but the "dark theme" that was set to automatically "turn on from sunset to sunrise". I disabled the automatic switch and set a custom schedule for it. For now, the issue seems to be gone.

  • @sonoro

    I never had turned on automatically night light or theme from light to dark, but the problem is still there.

  • Ah I see. So there seem to be other causes as well. Hope ASUS will be able to fix it quickly with the provided logs.

  • It was the weather app for me too. When I disabled the location detection in the background, everything went back to normal. I also found a system app always trying to get access to my location. It's called nextapp and by default it doesn't have a location permission and you cannot change that.

  • Same issues. LocationService is draining my battery.

  • Hey everyone,

    The R&D is working on resolving the issue however, the team has come up with a temporary fix by uninstalling Google play service updates.

    Uninstall Google play service by Setting>all apps and notification> see all apps>tap more option>show system>google play service>tap more option>uninstall updates.

    After uninstalling updates you need to reboot the phone. This should make the GPS icon disappear.

  • Can confirm this "fixes" the issue on my device.

  • @Mansi_ASUS I'll try and I'll let you know, thanks!

Sign In or Register to comment.