ethernet adapter keep disconnecting during games

Mazen JunaidiMazen Junaidi Level 2
edited August 20 in ROG Phone 6

hello everybody,

i just bought rog phone 6 three days ago and i noticed some glitches here and there and after searching on internet i found that alot of this bugs or issues happend to other users so i will not talk about it now because majority of that issues is UI related and u can live with it untill receiving new update, but my issue that am gonna talk about is reason that i bought this device and its not accepted at all which is (ethernet adapter connection keeps droping and disconnecting during the game ) yes its gaming phone and the connection keeps dropping. i tried to do many things to fix the issue but nothing solve it, i tried this : unistalled un-nessessery apps+restart device+restart modem+factory reset device ...and nothing solve the issue than i tried to disable the (ARMOURY CRATE) app and i felt that the performance of my device and ethernet connection become slightly better but the issue not solved ...so any one faced something like this. BTW am using good brand adapter (powerology brand) and this adapter works flawlessly with my ipad mini and S22 ultra and am using (cat 6 and cat 7 cable) direct from the router. i wish to find solution for this issue because i cant play call of duty mobile because of this issue!!!


Model Name : Asus rog phone 6

firmeware : Android 12 with last security update

Not rooted

Frequency : sometimes 3 times during the game, sometimes 5 times, sometimes the system not recognise the adapter, sometimes the system takes more than 2 minutes to recognise the adapter, sometimes i need to unplug the adapter 3 times to recognise the adapter

idont know which app causes this and the apps installed on my device is : whatsapp, messenger lite, call of duty mobile


This happend with the USB-C 3.1 located at the left side of the device ( not bottom )

«1

Comments

  • Mazen JunaidiMazen Junaidi Level 2
    edited August 20

    i wish to fix this issue and others soon.

    other issues i noticed from my experience :

    1- random restart

    2- finger print failed many times during a day

    3_ Audio is garbage despite i installed last update, there is missbehaving when calling or watching youtube, i can hear eco sound, it feels like someone talking inside water effect, i noticed that sound changeing while watching one video on youtube, the volume go up than go down and suddenly the voice become deep and i cant understand anything and at the end of the video the coice become normal !!!!!!!!

    4- The light sensor doesn't work well

    5- Random homescreen freezing

    6- weired sound inside headphone while playing call of duty mobile

    7- i tried to upload some photos from the gallery app by sharing some photos to google drive (which is allowed in all android devices ) but i couldn't because the system limitation allowed me to share only one photo!!! so all i did that i uploaded all the photo by going to google drive app than i pressed the plus button inside google drive app and uploaded all the photos !!! so i wish to make it possible to upload several photos or files direct from gallery app

  • It looks like a compatibility problem, it is not normal that it is necessary to make several connections and 2 min to initialize the internet, this first point indicates that there will be problems.

    Note, powerology does not seem to be a manufacturer, and not at all specialized in network hardware, it is a multi-product OEM, from blinders to vacuum cleaners, which buys from manufacturers and affixes its brand, even if the problem does not exist. is not imputed, it is not a quality guarantee and impossible to have advanced technical specifications, especially on the chipset, Asix, corechips, realtek, others?, this is the most important info that would immediately to know if it is a compatibility problem, Rog 6 or other. Asus is not better, impossible to know the chipset of the Professional Dock

    Regarding operation with Apple and Samsung, it's normal, all manufacturers ensure this minimum compatibility, the problems start with other brands or consoles.

    Some tips for testing

    To eliminate a power problem, only connect the Rog 6

    Disables bluetooh and Wifi of the Rog6, Airplane Mode is ideal for testing

    Check that there are no energy savings on the ROG6 but also on the router.

    If possible, test with a USB-C Ethernet converter from another brand that certifies Android, which has worldwide distribution and support

    example https://www.startech.com/en-us/cards-adapters/laptop-docking-stations

    Of course, I do not exclude that the Rog 6 is in question, there is still a number of fairly large bugs, audio, the impossibility for a device to wake up the bluetooth ......

  • Mazen JunaidiMazen Junaidi Level 2
    edited August 20

    thank you funbike31 for your reply, actully i've tested everything possible to solve issue but am sorry to say nothing helped. i tried to disable wifi, mobile data, blutooth, switched on airplane mode, unplugged other ethernet cable, disabled all asus rog apps like genie and armoury crate, restart my router, factory reset my smartphone, ofcaurse there is nothing of power saving apps or features is enabled. i think that my last hope is to order asus dock station hub from any supplier to get more compatibility and solve this issue.

    regards

  • Unfortunately, it's been 15 months that each ASUS request answers "ASUS Professional dock" and I don't know any person and any site where it is available, it is no longer manufactured and impossible to find second-hand.

    No reason to uninstall software, the problem comes from the Core, at best it will work with a hub equipped with a specific chipset but which one? at worst there is a Bug and it will not work with an Asix, corechips, realtek for the most common.

    Try to see different sites like Xda and reddit if other users have a similar problem or on the contrary if they have tested a hardware that works

  • No, it's not a compatibility problem. It's a bug caused by the phone, presumably battery saving bs. As he mentioned before, other phones work just fine with the hub, meaning the hub is just fine. Since the drivers for hubs and such are pretty much stock things in the linux kernel and whatnot, that means there is no way this is an incompatibility problem, rather just buggy rog6 software adding on to the already insanely large list. I have most likely the same hub as he has, also a rebranded china thing, works perfecly fine with the Rog3.

  • Mazen JunaidiMazen Junaidi Level 2
    edited August 21

    Finally after several attempts i found solution came up (suddenly) wish to help developer solve this issue. actully it is a trick but it's solve the problem temporarily untill new software updae.

    the trick is ( plug the hub or the adapter than restart the device while the hub is connected, after the device wake-up you will receive notification (setup 3.1 usb.......) just click on the notification and thats it..enjoy) this trick proofs that there is no compatibility issue ( with hubs or adapters ) or hardware issue ...i think developer can fix this ASAP

    i will be very happy if someone has the same issue and this trick solve it.

    Regards

  • is this website for developers?

    i can see at the bottom of this page some people called Moderators and Leaderboard !!! will they read our comments and send it to developers??

  • Well done, finally done, at least one workaround

    You compared the speeds/latency PC/Android with SpeedTest Normally the moderators bring up the problems, afterwards, what R&D does with them and how they correct and above all check remains a mystery.


    @Danishblunt

    Hmm, I know it's included in the kernel but knowing Asus's diligence on updates, are the drivers up to date, the latest AX is for example 1.2 of 2020, RTL 2022

    Moreover for Vulkan Google requests 1.3 for Android 13, the Rog 5 should therefore normally evolve

  • Ofc ASUS don't 🤣

    Drivers are horribly outdated, but it should still be covered just fine. The bug is caused by something else as he has proven already, if it was a driver issue he wouldnt shouldnt be able by fixing it with a restart.

  • Mazen JunaidiMazen Junaidi Level 2
    edited August 22

    danishblunt,

    i think the issue not solved completely because after using (retart trick) the connection become stable and not dropping but i noticed when i connect the headphone 3.5mm to same hub or to device the issue back again and the connection start to drop again !!! so as you said and funbike31 i think the drivers need to update. actully new issue appear now that suddenly the sounds dropping inside the game despite the ethernet connection is good :((((( i think developers should update this ASAP because this is gaming phone....

    am wondering why developers ignoring important issues like this?! this device is more expensive than iphone and S22 ultra and this is 6th generation of Asus rog phone series, so all this issue should be solved earlier because ASUS is huge company.

    beleive me this device has too much good things to beat the biggest companies like 6000 ma battery, front speakers, headphone jack, smooth ui experience, touch responsive is amazing even if you compare it to iphone and sometimes i reduce the touch responsive by disable ( gloves mode) because of high responsive, and the camera not bad like what people said ofcaurse its not as goog as iphone 13 or S22 ultra but sometimes it gives me better results than both, anyway i wish to fix all of this issue soon or i will sell the device and i will never ever think of this company brand the rest of my life

  • Mazen JunaidiMazen Junaidi Level 2
    edited August 22

    i just bought new adapter and same issue happen, messege said ( comunication quality may affected by 3.1 usb....) actully i dont undarstand what this messege mean

  • I already told you, it has nothing do to with drivers, it's just ASUS's horribly buggy software and honestly I don't expect them to fix it within the next year.

  • i just received august update with some fixes here and there, but the ethernet connection dropping not fixed !!!

    so shall i wait next update or what ? why no one is answering?

  • any developer van tell about compatible ethernet brands with my device?

    is belkin, anker, adam, ugreen compatible with ASUS ROG PHONE 6 ?

    why ASUS PRO DOCK not available in any website in the world ?

    helloooooo

    hellooooooooo

    ????

  • Mazen JunaidiMazen Junaidi Level 2
    edited September 7

    i contacted ASUS support team and they told me (we tried CASA adapter and it works fine ..)

    after i read that i went to google and searched for this CASA products and i found nothing related to this name except (high speed company working in 5G towers and something like that ) than i found company called (ADAM) making adapters with CASA name on it !!! so it means that CASA is a technology not (product)...anyway i found at the end that the adapter i have which called (CHOETECH) has the same specs as below :

    -Compatible with IEEE 802.3, IEEE 802.3u, 802.3ab and IEEE 802.3az-2010 (Energy Efficient Ethernet)-

    Support IPv4/IPv6

    despite all of that !! this technology or adapter that have same CASA technology doesn't work and keep disconnecting!!!!

  • I already told you it's the buggy software on the Phone. It doesnt matter what you buy it won't work. You can either start listening to what I say or keep spending your time and money on docks only to dissapoint yourself over and over again.

  • Danishblunt ididn't buy anything all adapters i mentioned are already here before buying ASUS ROG PHONE 6, all am trying to do is giving some hope and chances before selling the device.

    i contacted ASUS SUPPORT TEAM by email and they tried to fool me by saying that this issue not exist and ethernet adapters from ASUS or another brand working flowlessly.

    so i wanna tell them that all the youtube streamers suffers the same and they showed that on youtube, and all of them receiving the same messege (comunication quality may affected by 3.1 usb....) and majority of them converting to wifi....

  • Mazen JunaidiMazen Junaidi Level 2
    edited September 7

    because am looking to start streaming in the future that make me watch too much game streamers daily and that give me a good knowledge about best devices for streaming and performance specially in games like PUBG and CALL OF DUTY MOBILE.

    anyway i will send you link for the most famous youtube streamer called (parker the slayer) he bought ASUS ROG PHONE 6 before 2 days and try to watch his last videos to see the (error messege)that i mentioned before.

    i tried to send links here but looks like ASUS dont like that !!! anyway i will type the name of the streamer and the name of the video and the exact time that issues show-up

    first video : youtube

    channel name :parkertheslayer clips

    video name: asus rog phone6-most powerfull gaming phone(unboxing+cod mobile.

    time: 1:50 minutes usb 3.1 to hdmi issue


    second video : youtube

    channel name:parkerthe slayer clips

    video name :parker vs hacker | cod mobile

    time : 2:30 minute same error messege that show up to me before ethernet disconnection (communication quality may be affected by 3.1 usb)

  • @Mazen Junaidi

    USB-C on the ROG6 is like audio, when it's not what we'd expect in 2022 on a high-end device we don't talk about it at all, so that way we are covered against a defect or an advertised feature that does not work.

    Check the USB-C specifications on the official site, the port does not even appear when there are 2.

    Ditto on the manual, there is a line that specifies that only the side port is displayport compatible, without specifying the version (1.1 to 1.4 unknown). You have to go see the video possibilities to determine the version, 1.2 in this case.

    Exit thunderbolt compatibility so

    For USB-C 3.1 no indication Gen 1, Gen 2

    In short, what you can do if you haven't already done it, remove all that can be a dialogue with usb-c

    disable usb audio routing, check apps via usb

    Finally, the message indicates that the usb-c port limits the possibilities of the other usb-c port, so if you have a 100 mbps router or even 10 mbps it is to be tested.

    Finally, the last point to do (which should have been the first requested by an asus tech is to activate the log and send them for analysis) but on the English discus it does not seem to know this feature, here are the codes for info to their attention

    On: .19595+=

    Off: .09595+=

    Attention, the volume can be consequent, it must be stopped as soon as the problem occurs, the ideal being that the problem occurs in the first 3-5 minutes, if this is not the case, stop, erase and start again.

    You send them the log in private message, it will change them from the copy/paste message for Wifi HS of the rog 5

Sign In or Register to comment.