Armoury Crate missing most key features, like the HOME tab (i)

QuantumWakeQuantumWake Level 1
edited August 5 in Others
  1. System: Windows 10
  2. Battery or AC: Both
  3. Model: ROG GL703GS
  4. Frequency of occurrence: 100%
  5. Reset OS: /
  6. Screenshot or video:

========================

Detailed description:

Hello ! I have been trying to install Armoury Crate for a while now without success.

I apologize already as I've seen this exact question has already been asked, but it was closed without any public response given... but I was redirected here by ASUS Support to state my issue.

Armoury Crate is missing most key features :

  1. No HOME menu (i) shows up at all
  2. No device menu is available either : the icon shows up for half a second on startup, but goes away on its own afterwards
  3. No game visual menu shows up either

I wanted to install Armoury Crate for the fans control feature, but the installation isn't proper despite my many attempts at doing it right.

The remaining menus are lacking most features: the Aura Sync menu is unable to find my keyboard's LEDs -which do function as they light up on start-up, shutdown, and in sleep mode, but not through Armory Crate-. Sometimes it crashes trying to look for it.

The scenario profile menu shows a total of 4 options, two of which are non-fonctional Aura options, the rest being the speakers volume and the cache clearing feature. The "add apps" option shows up in German as well : "optionen anzeigen", but that probably just is a slight oversight that was left in the French translation. I had fans profile (silent, turbo,...) available at some point but now it's gone as well.

I've also noticed that, on the taskbar, when hovering Armoury Crate, that there are play/stop/advance buttons below the window preview, exactly like for the Photos or Music apps, meaning Windows somehow is thinking Armoury Crate is a video/music player..?


I can't get a clean installation, even after trying everything I could think of : downloaded and ran the uninstallation tool to clean it all up, rebooted the laptop afterwards, installed the Full Installation Package with the options I wanted, updated the software to the latest version, updated ASUS services,...

On one attempt, I actually managed to get the HOME menu to show up, but it was still lacking nearly all features, notably fan control.

I have found records of other people with the same problem, dating back years, none of which with an associated fix unfortunately.

What can I do to get Armoury Crate and the fans control feature to work?


[On another, unrelated, note: the text editor of this forum have issues with paragraphs and character deletions, which were super annoying to deal with.]

Comments

This discussion has been closed.