ROG Phone 2 fps drop on Wild Rift with even Low graphics + X Mode

kelvinthenedykelvinthenedy Level 1
edited June 17 in ROG Phone 2

Please tell us some basic information before asking for help:

  1. Model Name: ROG Phone 2
  2. Firmware Version: .215
  3. Rooted or not: no
  4. Frequency of Occurrence: Everytime
  5. APP Name & APP Version (If your issue relates to the app): Wild Rift

In addition to information above, please also provide as much details as you can, e.g., using scenario, what troubleshooting you've already done, screenshot, etc.

========================================

I have enabled x mode on wild rift, and i cannot even play the game with high nor medium graphics without fps drop, even with low graphics it still happens but less frequent. I tried gaming tuning level 3 & max cpu & thermal limit still doesn't work. I tried hardcore setting following wild rift official setting (from taiwan i think? I forgot) still doesn't work. I restarted and redownload the game still doesn't work It happened since Android 11 update... The cpu cannot stay at 2.96, it keeps fluctuating to 826 mhz. I'm so disappointed with this so called high performance phone. Is all of this just a gimmick?

I also tried to change the driver preference to System Graphics Drivers and it didn't do anything

Comments

  • Here are some screenshot that i've tried

  • Android 11 is clearly not good for gaming compared to Android 9 and 10. Especially .215 update seems really bad, that’s why I’m still on .211. I personally don’t play games so much, so Android 11 is fine by me.

    But I recommend you to downgrade to Android 9 or 10, if your main purpose is gaming.

  • Thank you. Yeah i wonder why asus doesn't fix it until now. And i actually find some sort of a solution by setting cpu & thermal limit to max and also setting the game profile "same as system setting" which means you have to turn on & off X Mode manually each time you play, but it helps a ton. It causes nearly 0 fps drops with high graphics + high resolution + high effects + post-processing (it still drops when i play with voice call on but it happened after like 1.5 hours playing and only happened like 1-2x compared with almost every teamfight beforehand). But still, if this is the solution, then it makes all the other settings useless and asus still need to fix this :)


  • Thread automatically closed due to inactivity. If the reported issue has not been resolved or you require further assistance from one of our moderators, please create a new thread and we will be with you shortly.

This discussion has been closed.