USB-C/thunderbolt problem no signal to external display

  1. System: W10
  2. Battery or AC: AC
  3. Model: UX391.FA
  4. Frequency of occurrence: Always
  5. Reset OS:
  6. Screenshot or video:

========================

Detailed description:I have had my computer for almost 2 year. I have never had any issues with the docking station (USB C) were i have my external monitor and mouse and keypad connected. For two weeks ago the display stoped working. It lights up when i am connectint to the docking station but it gets no signal so after a couple of seconds it turns of.

I can also say that there is nothing wrong with cables or dock. The mouse, keypad and everything else works just fine...But not the display.

I have also tried to connect my other laptop (lenovo x250) and with that laptop everything including display works. So, there is nothing wrong with the equipment.

«1

Comments


  • Hi @YukonCharlie,

    Try to check if there are specific drivers for your dock from the manufacturer. I had to update drivers for my dock after a windows 10 update, because my monitor stopped working...

    For windows 11 (clean install) the drivers for the dock were automatically installed by the system.

  • Hello Charlie,

    If you connect only the monitor to the dock, and then to the computer, does it work?

    Is the monitor detected and shown in device manager?

    Thank you.

  • No! Nothing happens...

    I have tried the USB-c to hdmi adapter that was included in the package wheh i bought the computer. This adapter has always worked before but not now . When attaching that one i can see it in the USB view as a USB-C to hdmi adapter. But i dont get any signal to my display this way either.

  • Hello Charlie,

    So the monitor was not listed in device manager?

    Which monitor are you using?

    It is having completely black screen or there is a notice of "no signal"

    if you adjust the resolution, does it help?

    Thank you.

  • It is not listed at all..

    Just black screen and i cannot change resolution at all..it never comes up in any

    The model is: u32r590cwu (Samsung)

    meny for display settings.

    The strange thing is that it worked for like 4 weeks ago (and it is still working on my other computer).

    I saw now that when i start the computer it says something about "The thunderbolt APP is not in use..."

  • edited December 1

    Hello Charlie,

    You can try to reinstall the USB drivers in the device manager? All 3 ports.

    And how about in safe mode?

    Also, can you find another monitor to connect, just to cross check?

    Thank you.

  • I have tried to reinstall the USB drivers, nothing happens..


    I have tried another display but still have the same problem...


    What type of drivers is it that should look for another display?

  • I getting mad....Cannot use the computer that well without a external display. Think it is strange that everything else i connect to different USB C docks works, printers, memories, mouse etc...but not the display.

  • MotoWiZMotoWiZ Level 2
    edited November 28

    Hi @YukonCharlie:

    I was having problems with thunderbolt, not like you, but couldn't update the drivers, so I did the following and by this order:

    1 - Follow this link instructions:

    2 - In Device Manager, under System Devices (my Windows is in Portuguese, so I'm not sure it's this name) locate Thunderbolt controller and do the following:

    • Right click;
    • Update controller;
    • Seek controller in computer;
    • Enable choosing from a list of available controllers in your PC;
    • Choose the last version (most recent), the one you downloaded from Asus website. If the driver version that you downloaded doesn't appear in means that it wasn't installed and you have to install it correctly;
    • Restart your laptop;
    • Verify again that, now, the version installed for the Thunderbolt is the right one, by going again to device manager, but this time right click thunderbolt, then properties and see in the controller tab that the version is equal to the one you want;
    • Verify if now the monitor works...
    • If the monitor still doesn't work, you should download older driver versions from Asus Website, repeat the process of installing the version you want, till you find one that makes the monitor work again.

    3 - Once the monitor works, open Microsoft store and install thunderbolt control center.

    Please, give the community feedback to know if it worked.

    Good luck!!

  • Thanks for your support.

    I have reinstalled all USB drivers and they are updated, still the same problem.

    What i can see i have problems with the thunderbolt port. I tried tro reinstall the drivers but then i get the following in the log fil:

    [3D60:20B8][2021-11-29T11:39:10]e000: Error 0x80070643: Failed to install MSI package.

    [3D60:20B8][2021-11-29T11:39:10]e000: Error 0x80070643: Failed to execute MSI package.

    [16F0:410C][2021-11-29T11:39:10]e000: Error 0x80070643: Failed to configure per-machine MSI package.

    What is MSI package?

  • It's a Microsoft installer package...

    Google for 0x80070643, and try to figure out what is wrong.

    I think that there's a windows update that is not going correctly, see historical in windows updates to see if you find something suspicious.

  • I have now tried everything:)

    My last option was to reinstall the operation system from scratch...I did it and what happened? Same problem arise....I also get a message at the first start up that "this applications is not running". So, i cannot install the new updated Thunderbolt drivers so i am stucked.

  • Try to uninstall and delete the drivers for thunderbolt. Just right click it in device manager and select uninstall and then choose delete drivers also (I don't remember if it has the option uninstall or only disable)...

  • I have now uninstalled the drivers and reinstalled them. I still have the same problem (but now with errors at start).

    What part of the computer is it that has to do with all data over the USB port?

    Everything else on the USB-C dock still works just fine...But no image on the screen...It seems like that the computer dont understand that there is another display connected.

  • I see that in thunderbolt controll center it says that i dont have any thunderbolt devices enabled/connected...When using my other laptop it says that it has one device connected..

  • The thunderbolt is located in device manager under system devices.

  • edited December 3

    Hello Charlie,

    Can I have a screenshot of your Windows update history in the past 2 weeks, around the time that the issue occurred?

    Hope you still have it.

    Thank you.

  • Regarding the update history i was so upset last time so that i did a new installation...so no history. When i looked at it before i couldnt see any update at this time.

    Now it looks like this:

    It still seems like the driver for the thunderbolt doens have found any hardware...

    It is empty

  • Hello Charlie,

    So....you are using Win11 instead of Win10? and the issue happen with Win11 or Win10? or both?

    Thank you.

  • I had w10 when it started. After trying everything i last week reinstalled everything and then with w11, with hope that it would be solved:)

    I wonder if there could be something wrong with the hardware..But the computer had been connected to the dock the last three months so nothing should have happened.

Sign In or Register to comment.